Chrome OS Updated to v85 Today And Arduino Web Editor Now Does Not Recognize UNO

Good evening,

Today my Chromebook updated to version 85.0.4183.84 from 84.xx and now the Arduino Create Web Editor does not recognize my Elegoo UNO R3 that is connected via USB. The web editor worked with the Elegoo UNO R3 for over a year and was last used a week ago. The only real change to the computer in the last few days was the latest Chrome OS update.

To troubleshoot I have:

  1. Reset my computer several times.

  2. Hooked and unhooked the the board's USB several times.

  3. Unhooked all the wires leading off the board to connected sensors.

  4. Reset the board manually with the reset button

  5. Opened Arduino Web Editor in an incognito window

  6. Cleared my cache

  7. Made sure the software bill was paid this month

8 ) Made sure the Arduino Create extention is installed and activated

  1. Disabled the ad blocker

  2. Verified the USB port works by connecting a Kindle and reading the contents of the Kindle's directory.

I am at a loss as to why the Web Editor stopped recognizing the UNO today. Any help is appreciated.

Thank you

I Have the same problem. Since last chrome os update there is no chance to connect my Mega 2560-Board via usb to my acer chromebook, no sketch upload to the board. The subscription-version of the arduino create app (V1.0.15.1 in chrome web store) is installed.
Thank you very much for help.

Same issue here. Multiple Arduinos (UNO, Nano, Mega MKR WIFI 1010 etc) , different USB cables. Both on Chrome OS and Chrome on Windows. I have disabled chrome extensions, reset settings to defaults, made sure there where no Chrome://flags set and nothing works. I have no option to select a port.

Incidentally, The regular Arduino IDE now works under Linux on a Chromebook without issue, so maybe I will just start using that. I just loved the convenience of having all my projects stored in the cloud with Arduino Create...


I have the same problem.
I tried some solution to solve this problem on the chromebook.
The arduino IDE using linux(beta) on the chromebook does not recognized the arduino uno.

First, a powerwash of ChromeOS. -> nothing has worked. A powerwash didn't completely downgrade it.
Second, changed channel to beta version. -> nothing has worked. The arduino web editor does not boot up well in the beta version.
Finaly, changed channels back to staible. -> A powerwash was automatically performed, and ChromeOS version was downgrad to v72. Then, the arduino create recognized the arduino uno.

However, ChromeOS v72 began v85 by automatically OS update. Then, the arduino create does not recognized the arduino uno.

I found dev/ttyACM0 not working properly. So that, tha arduino IDE and ithe arduino create does not recognized the arduino machine in ChromeOS v85.

I think the only solution is to change ChromeOS to v72 or wait for the ChromeOS more update.

It seems to be possible to fix the version of ChromeOS for a fee (google suite).

The strange thing is that it works on codebenders site, without a plugin. I've had som issues on this site. Does anybody have any experience with codebender? Does it have the same possibilities or is it better or worse?

Same for me. After updating to Chrome OS 85, Arduino Create and Arduino IDE (Linux Beta) do not recognize any arduino (uno, nano, leonardo) I connect to the Chromebook. However, codebenders site DOES recognize the arduino boards.

Furthermore, looking at the background script for the arduino create chrome app, I get the following error in the chrome console "window.localStorage is not available in packaged apps. Use instead.". This error does not show in console for codebenders app.

Hi all,

We recently released a temporary fix, solving the issue caused by Chrome OS v.85 which was released with several versions of the app. The latest version should have the official boards available.

Check which version of Arduino Create you have by going to to chrome://extensions/ and select Arduino Create. Under 'Version' you will see which version you have installed. The latest version at the moment should be

Clones or third party boards such as Elegoos are not meant to work with the app.

Best Regards,

Clones or third party boards such as Elegoos are not meant to work with the app.

The Elegoo UNO used to work in the app and now it does not. Did something change? Are Elegoos not meant to work with the app or is the app not meant to work with the Elegoo?
I have other boards from other manufacturers and a Chromebook - now I am literally dead in the water. I am paying for a subscription but it sounds like I cannot use it anymore unless I buy Arduino branded boards?
Thanks for your reply explaining what is happening.