code no longer uploads to board

Hi, I've been working with an Arduino NG and things have worked very smoothly, but I've encountered an unusual error. I keep trying to upload new sketches to the Arduino, and everything appears to work (meaning - the Arduino environment does no relay any error messages) but then when I power it seems as if an older version of code I uploaded is still running on the board. I've tried a lot of different sketches to test this and each time it hasn't worked. An old sketch I had running which turns pins 2 and 3 high still seems to operating on the board. Any suggestions?

I'm having the same problem, It had worked smoothly until now. the IDE will thinks everything is loaded OK, but for some reason, the old version cannot be over-written and stays in there.


I have noticed that this happens sometimes when you have not selected the proper chip in the Arduino 0007 Software.

In the tools>microcontroller menu, select the name of the chip that is on your board: Atmega 168 or Atmega 8.