Collegare motore stepper ad arduino

Salve a tutti, questo è il mio primo post su questo magnifico forum quindi colgo l'occasione per salutare tutti.

Premetto che non ne capisco molto di elettronica (praticamente niente), comunque ho la necessita di collegare al mio mitico arduino uno un motore stepper. Il motore dovrà essere circa una decina di metri lontano da arduino, e non sò che cavi acquistare per collegarlo. Spero che qualcuno può aiutarmi, al momento ho questo negozio a portata di mano http://www.partco.biz/verkkokauppa/index.php?cPath=1919, tra i i cavi che ci sono quale sarebbe il più consigliato? P.S. il motore stepper che prenderò è questo http://www.partco.biz/verkkokauppa/product_info.php?cPath=5&products_id=15490

Prova a dare un'occhiata a questi motori: http://www.sanyo-denki.com/Data/Servo/catalogs/F2_ver1.pdf

Ti consiglio di utilizzare quelli con la 485 o quelli già con il drive a bordo, quindi devi fornirgli un treno di impulsi. Per utilizzare il motore che hai linkato ti serve un drive, che è l'integrato che c'è fra i suggeriti, però devi stare attento a come pilotarlo altrimenti lo bruci (il drive). Ti consiglio di dare un'occhiata a questo link se vuoi approfondire l'argomento. http://www.vincenzov.net/tutorial/passopasso/stepper.htm

Ok grazie mille, ora inizio a capire. Pensavo era più semplice.... Purtroppo non riesco a trovare un motore stepper con driver già integrati, quindi stavo pensando di costruirne uno semplice. Pensi sia possibile costruirne uno con l'integrato L293D come mostrato in questa guida http://www.tigoe.net/pcomp/code/circuits/motors/stepper-motors Oppure pensi possa andare bene anche quello che viene mostrato nel link che mi hai mandato? Altrimenti conosci altre soluzioni possibilmente economiche?

Se usi quegli integrati devi solo star attento a non attivare contemporaneamente i mos sullo stesso ramo del ponte ad H ma sempre in croce.

Ho comprato l'integrato L293DNE e l'ho collegato come mostrato qui http://www.tigoe.net/pcomp/code/circuits/motors/stepper-motors Il problema è che ora non so come collegare gli out allo stepper, ho provato a collegarli un pò a caso (lo so non è un grande idea) ma chiaramente il motore si muove (avvolte trama solo) un pò come vuole. Dal mio stepper escono 5 fili : giallo e nero dalla parte superiore, rosso blu e bianco da quella inferiore. Qualcuno può aiutarmi??

P.S. Lo so dovrei studiare un pò più di elettronica prima di cimentarmi in queste cose :cold_sweat:

Ok ho risolto, togliendo i transitor e mettendo il controllo con 4 wires (cavi), chiaramente ho anche modificato la riga di setup in arduino cosi: Stepper myStepper(motorSteps,8,9,10,11);