Compatibility Wifly Shield (firmware and IDE)

Hello everybody,

Anyone knows the firmware and IDE version that are compatible for the Sparkfun Wifly Shield?
I am actually using the default firmware version, the oldest one, with the Arduino 1.0.6 IDE.
It doesn’t work very good so, anyone knows a newer compatibility?

Thank you!