Connection issue to APs

Hello community

I have an issue to connect my MKR1000 to my WIFI access points. MKR1000 has the current firmware 19.4.4 and I am using wifi101 library 0.10.

I tried with the example code delivered. Regardless if I use no encryption or WPA2 encryption the scetch runs in an endless loop and tries to connect without success. The scanNetworks example shows all available SSIDs.

I have tried with all my THREE different access points and non works (2 x D-Link and 1 x Technicolor) with 2.4 GHz and 802.11 g/n

Beeing frustrated I tried to use my Android smartphone as WiFi hot spot (with WPA2 PSK). Surpisingly that worked. So in principle the Wifi modul works but only with my android smartphone.

Does anyone have an idea why the connection to my APs does not work?

:confused:

Hi @Gitagak,

Are your access points configured for WPA2 mixed mode? There's an open issue on Github regarding this: https://github.com/arduino-libraries/WiFi101/issues/75

No encryption is working for me last time I checked, could you please share an example sketch to illustrate the issue?

Hi, I use WPA2 exclusively or none for testing purposes. The scetches are the examples available in Arduino IDE delivered with the wifi101 library.

Coincidently I've had the possibility to change my router provided by my Internet Provider (unitymedia). Today it came and I instantly tested if the MKR1000 could connect to the Wifi (WPA2 encrypted). Fortunatelly it worked well. My old router is Technicol TC7200, my new is the "Unitymedia Connect Box" (by Compal). Summarized the MKR1000 (or the WiFi library) shows a VERY MISERABLE WiFi compatibility. This should be improved urgently. Without my new router the board would be useless for me.

Hi @Gitagak,

Please go ahead an open an issue for this on Github: https://github.com/arduino-libraries/WiFi101/issues

Since the issue is mostly caused by the WINC1500 firmware, which Atmel controls. You'll also have to create a support case with Atmel: http://www.atmel.com/forms/Secure/verifylogin.aspx?target_url=salesforce&ssotarget=customers%2F500%2Fe%3FretURL%3D%252Fcustomers%252F500%252Fo

Once that is done, please provide the case number in the Github issue you created.

Hi all,

I have the same problem. My MKR1000 is not connecting to my internet router.
This is also independent of WPA or WPA2.

The second thing Is that I want to connect the MKR1000 to a raspberry pi 3B with an AD-HOC network.
With the example ScanNetworks from the WIFI101 Lib I can see this network.
But even if I try to connect to it with the example ConectNoEncyption it will not work.
I tried also to set a IP Address because the pi have until know no DNS.
But also this was not working.

Can somebody help me on this ?