controlling motor with Syren Driver

First off, I'm still very new to arduino.
I have a small amount of experience with statement programming but i'm not completely new with it.

I was working on a project using Control Large DC Motors with Arduino! SyRen Motor Driver Tutorial - YouTube as a reference.

pretty much the only thing I need my project to to is run a motor back and forth until something trips a proximity sensor and the loop stops.

... Unfortunately the Sabertooth library isnt working well with the Arduino software. Its saying that the library is invalid. I'm not sure if I'm not adding it to the libraries correctly... or if sabertooth is no longer compatible... in any case, I dont have experience to come up with a solution to get around this, i've based my code on what was in the video. ...

I've spent a pretty penny on the materials for this project but now I'm kind of lost. any help would be greatly appreciated.

Post a link to the library that you want to use, post your sketch and a copy of the entire error message(s) that you get when attempting to compile the sketch and we can help. Please read the "how to use the forum" stickies, and any links, to see how to format code and post code and error messages.

Welcome to the forum.

This is the Library Dimension Engineering - Libraries for Arduino

I cant get the same error message about “invalid library found” arduino is ignoring the library competely.

I’m using the same code in the video because I didnt even get far enough last night to start changing it. when I Sketch>include library>Sabertoothlibraries it shows up as a blank space.

#include <SyRenSimplified.h>

SyRenSimplified ST; 

void setup(){
  SyRenTXPinSerial.begin(9600); // This is the baud rate you chose with the DIP switches.  
  ST.motor(1, 0);   
  }

void loop(){
ST.motor(1,0);  

delay(100);

ST.motor(1,100);  //-127 FULL reverse.  0 is stop.  +127 is FULL forward

delay(2000);

ST.motor(1,0);

delay(100);

ST.motor(1,-100);

delay(2000);

}

the error messages comes back as

"Arduino: 1.6.4 (Mac OS X), Board: “Arduino Uno”

sketch_may09a.ino:4:29: fatal error: SyRenSimplified.h: No such file or directory
compilation terminated.
Error compiling.

This report would have more information with
“Show verbose output during compilation”
enabled in File > Preferences."

The libraries are likely not installed correctly in the right place. You have a Mac so the Windows installer won't work and so download the zip file. The library manager tells me that it is not a valid library so can't use install zip. One must manually place the libraries. See the install.txt file in SabertoothArduinoLibraries.zip. I copied the 4 files from SabertoothArduinoLibraries.zip into my libraries folder and the code that you posted compiles without errors or warnings.

In the SabertoothArduinoLibraries.zip file there are 4 folders. Copy those 4 folders to the libraries folder (and make sure to restart the IDE). Like I said, I don’t know Mac, but that worked on my Win 10 machine. Attached the SabertoothArduinoLibraries.zip file to make sure we are working with the same thing.

I see where I said files in my prior post. Sorry for the confusion. The library install process can be daunting at first as there are pitfalls. Most current libraries will install with the library manager which makes it easy. If a library is not compatible then not so easy.

SabertoothArduinoLibraries.zip (382 KB)

Yes!!
perfect. gosh such a small problem, but such a huge hurdle.

much appreciated.