Device is offline in Arduino IoT cloud

I'm using "Doit ESP32 devkit V1" device, I want to connect it to the Arduino IoT cloud so I added it as a device in my thing but it is offline although it is plugged to my laptop. How I can make it online or ready to connect?
Is there something I should do with the Arduino IDE or Arduino Create Agent?


Hi @haidar_bazzoun. Did you upload your Thing sketch to the ESP32 board yet?

No I didn't because the device is offline, I can't upload.

You got it backwards. The device is offline because you didn't upload. It won't show up as online until you have uploaded a Thing sketch and the board starts to communicate with the Arduino IoT Cloud servers via the network.

The reason you can't upload has nothing to do with offline or online status. The reason you can't upload is because the Arduino IoT Cloud editor only works with the official Arduino boards (e.g., Arduino Nano 33 IoT). Those boards have a dedicated USB VID/PID pair owned by Arduino that allows the editor to automatically detect which port the board is connected to on your computer.

The manufacturer of your "Doit ESP32 devkit V1" board did not purchase a custom USB VID. Instead, they use the generic VID/PID pair provided by the manufacturer of the board's general purpose USB to serial adapter chip (e.g., WCH CH340, Silicon Labs CP2103). There is no way to identify a board from that VID/PID pair because the chip might be on any type of Arduino board, or even just some random consumer electronic device that happens to be attached to your computer.

But this is not really a problem because you can also use Arduino Web Editor to upload your Thing sketch and Arduino Web Editor does not require that the board can be automatically detected. The Arduino IoT Cloud editor is just a stripped down variant of Arduino Web Editor. The idea is to remove all but the absolutely essential functionality to make things less confusing for the user. But in the case of the ESP32 and ESP8266 boards, that stripping down went a bit too far by making it impossible to use!

So just click that </> Open full editor button and your Thing sketch will open in Arduino Web Editor. Once there, you can select the port of your ESP32 board from the menu at the top of the Arduino Web Editor window and then upload the sketch to the board. Once that is done, you can click the Go to IoT Cloud button to return to Arduino IoT Cloud. If everything was configured correctly, you should now see that your Thing is online.


I'm really grateful for your help, you helped me understand the issue and fix it.

You are welcome. I'm glad to hear it is working now. Enjoy!

hello, I've done what you suggested, but the device I'm using is still offline. actually the program can be uploaded, but when I look at the dashboard, the value received is still not correct. I hope you can help, thank you



I am having the same issue, even though my micro-controller is connected to a laptop I can not see the online status from the Arduino Cloud. Also, it is showing the "fail" message in the serial monitor.

This is the photo:

I am just not sure how Nano RP2040 Connect really connects to my WIFI, maybe I need to implement a WIFININA file somewhere, but I never see people doing it in the online videos. In the videos look simple, but I am having a hard time with this Microcontroller.

I hope you guys can help me.

1 Like

That is not necessary. The "Arduino_ConnectionHandler" library does it for you.

From the SSID, it appears your Wi-Fi router is using the 5 GHz band. That frequency is not supported by the u-blox NINA-W102 Wi-Fi radio of the Nano RP2040 Connect.

It is likely your router also supports the 2.4 GHz band the Nano RP2040 Connect can use. So just make sure to configure the network credentials of your "Thing" to connect to the 2.4 GHz SSID of the router.

1 Like

That can really be the solution. Thank you!

You are welcome. I'm glad if I was able to be of assistance.

12 posts were merged into an existing topic: Port option not showing up for ESP32 on IoT cloud

Hi, I have a similar problem. I can compile and build and upload through the web editor, but when I go to Arduino IoT Cloud it stays off-line. Can't find the problem.

Its a bit weird because even when the Nano 33 is fully disconnected, the "cloud" finds it. But it never goes online through the Cloud. I have deleted it, fully disconnected, but it seems to still find some Ghost device. Not sure what to do. I am on a Mac. Programming over USB works fine in IDE 2.0 .

1 Like

things (which is achieved immediately with a very expensive ENV-Shield+MKR1010 board) is neither "fauximo" or Tashmota limited!!!!!

It's called rip-off and cheating, because they deceive people knowing in advance that it (cloud connection and also Alexa) doesn't work!!!!!!

I want to quote:

"the other boards have no "USB verification"


This means that as soon as you connect the boards to power or battery (where there is no "Arduino agent" ("USB identification"), the connection to the cloud is not given.

But this is fraud, because the device was "verified" during the initial installation (got its ID from the cloud) and these now require more Dtrom and WLAN, nothing else!!!! Just like Bylink, ESPHome or EadyESP, although these do not promise an "Alexa connection" and are completely free!!!!!

Hi @beatagerger

Please provide a link to the source of your quote. I'm having trouble understanding the context.

Blynk has both free and paid tiers, just like Arduino Cloud:

ESPHome is a software product, not a cloud service. You can't compare the two. Arduino also provides their software products without charge.

I am not familiar with "EadyESP" and didn't find anything relevant when I did a search.


I quoted from the letter to which I replied.

I'm also a "paying customer" on Arduino, annual amount, from the start, because I wanted to connect all devices to Alexa, so I only charge what I paid for, it wasn't/isn't free.

I'm angry because I've invested a lot of money and time, but it's not working.

I was hoping to get away from Home Assistant (ESPHome, a disaster, but it works) and Nabu Casa because Home Assistant messes up my devices (most notably Philips HUE and Node Red)

There is still a possibility with "SmartThings" (because of the Samsung devices account available), and also with Tuya, where you can bring your own devices into its cloud. SmartThings gets along very well with Alexa (less so with Google) but half of Asia is integrated in TuyaIot (as well as Ledvance or Hama, Ewelink) and it works with all other clouds, I will probably pass it on here.

I am angry and feel cheated, lied to and ripped off by Arduino. I was never concerned with annual subscription costs, I was willing to pay for them, but not for services that don't give anything.

Fauximo and Tashmota aren't IotClouds either, but by programming them you can pair devices with Alexa, instead of going through the difficult process in AWSIot of bringing devices to "Amazon Cloud". I didn't expect more from Arduino Cloud. It is sad that the installed devices can not only be found for Alexa-IotCloud, but not even in their own, i.e. in Arduino IotCloud... If you want to have devices, values, circuits in front of you, instead of a non-functioning ArduinoCloud, you should install a server (like Tashmota, EasyESP), you can reach them on the phone at any time. I'm not interested in operating the devices at the end of the world, but in my own network, whereby I prefer to pay for "server services". But it cannot be that the Arduino device, which is next to the router, cannot be found in the cloud, but the Tashmota watering system from Plantage can control Alexa. (free!!!!!)

that is the difference:
Tashmota+any board, especially ESP= accessible in any browser, i.e. on mobile, PC and Alexa Cloud
is free.
as well as installation of "fauximo"
Unfortunately, Termometer does not work in Alexa, but Shedule etc. does.

Annual fee (not free) only certain boards, works until it is connected to the PC, it cannot be reached by mobile phone or in a browser or in AlexaIitCloud.
Accessible only on the PC for AndroidIitCloud and also for Alexa.

But this is nowhere in the ArduinoIotCloud description (derivation), PC is only required for setup.

Logically, one then assumes that, just like every board, it must be set up ("flashed") either online or offline in the Arduino IDE, i.e. on the PC (or Android APP) (otherwise the board will not work) and then on the Place is set up as it was intended. It is connected to electricity (or battery operated), connects to the Internet via WLAN and is ready for the intended function/automation.

But that doesn't work in ArduinoIotCloud!!!!!!

Sorry, but I don't want a desktop device next to my laptop, an IotCarrier with MKR was not invented for such a purpose.

You are not replying to a letter. You are replying to a forum thread. The text you are "quoting" does not occur anywhere in that forum thread. So where did it come from?

I'm asking because I am not aware of any such behavior as you claim:

I'm no expert in Arduino IoT Cloud (my primary work is in other areas of Arduino), but I am not aware of any such limitations and have not experienced them myself. So I think it is more likely that you are either found some false information (there is a lot of it on the Internet), or perhaps have misinterpreted what you read. I would like to investigate and correct this, but I need access to the full context of your quote in order to do that.

There is a free tier of Arduino Cloud. It is called the "Free" plan:

That is exactly how it works. I'm controlling an LED right now on a MKR WiFi 1010 that is not connected to any computer.

If it is not working that way for you, then let's try to find the problem. You are only holding yourself back by jumping to conclusions about the cause of the problem.

Please provide a detailed description of the problem you are having:

Which board are you using as your Device?

Does the problem still occur when you use this very simple Thing?:

Does the board have access to the network you configured the access credentials for in the Thing dashboard or the Secrets tab of the Thing sketch running on the board?

How is the board powered?

please read the answers above...

I quoted from here:

How connected?

with power at 5V...
and please, don't look for something because of a connection.... A Nextion is also on it, and if something wasn't right there, there would be no advert....

I even set it up so that the LED blinks... It blinks twice, display and temperature measurement is okay, but in cloud it is not.

IP address (serial monitor) read, but I can't even find it in the router under connected devices, only when it's connected to the PC....

funny but, as an experiment I added my phone, it's always online in 5G(!!!!!)
the phone showed up as online in cloud.....

That post does not contain the text you "quoted".

You misunderstood the post. This is the process of setting up a Device as an Arduino IoT Thing:

  1. Configure a Thing on the Arduino IoT Cloud website.
  2. Connect the Device board to your computer with a USB cable.
  3. Upload the Thing sketch to the Device board.

The post you quoted is about performing step (3) above. This step does indeed require having the board connected to your computer. But once you have uploaded the Thing sketch to the Device board, the board will continue to work as that Thing as long as it has:

  • power
  • access to the Internet via a network

Once the Thing sketch is uploaded, a connection to the computer is no longer necessary.

You are only derailing your progress by jumping to conclusions. If your project is not working as you expect it to, provide details about the problem and we'll help out out.

I had a similar problem. Tried the methods above. What finally worked was not obvious. For some reason, some clipped text replaced my WiFi password. Once I entered the password, the ESP32S device synched up. I removed it from my PC and placed it in a simple USB charging port to ensure it was not connected via my PC and everything worked out. Your mileage may vary YMMV.