El Capitan - Arduino IDE serial port problems

Hi OldSteve,

  1. Chinese clone. Thanks for the catch. I followed Nick Gammon's instructions, and can update at the 2560 boot loader from a redboard (uno) . I have another issue where a sketch can upload to the 2560 only once with a fresh boot loader.

See

[Topic: Upload Timeout Error on Mega 2560 - Not Sure What Changed] https://forum.arduino.cc/index.php?topic=83079.msg2450514

  1. Official 2560 I removed the FTDI driver from Mac OS 10.11, anduse the stock driver. Uno serial is detected, but official 2560 board is not. I see some other posts in the forum on this, but no clues as to a fix or what to do to debug.

Thanks.

Read that Arduino IDE 1.6.6. is arrived. Anyone tried yet ?

Also no Luck here. I have installed version update 1.6.6. Arduino IDE, but not change anything. Still wrong driver, and can't upload script. (El Capitan iMac 2008 with Arduino UNO and MEGA16U2 1440-PH

cidiemme: I found this solution (https://www.kiwi-electronics.eu/blog?journal_blog_post_id=7):


Just like Yosemite, El Capitan requires kext driver signing. How this can be disabled in OSX 10.11 is changed however.

To get the CH340 drivers to work in El Capitan you need to use the new tool csrutil as follows:

Reboot and press CMD+R immediately after hearing the startup sound to boot to Recovery Mode Open Terminal Execute the following command: csrutil enable --without kext Reboot

Claudio

Perfect, this worked for me. At first seemed nothing had changed but after unplugging and replugging nano clone /dev/cu.usbserial came back :)

Thanks!

Anyone managed to use Official Arduino UNO R3 (not listed in ports) on mac Os X 10.11 El capitan without disabling SIP ??

For me the solution is: https://www.kiwi-electronics.eu/blog?journal_blog_post_id=7

So I got this Arduino DCcEle DCcduino UNO from my Pop. Trying to upload to it using USB cable to MacBook Pro, early 2011, running El Capitan.

No USB ports that are useful show up, just bluetooth and wireless.

Tried some of the stuff suggested, nothing works. Don’t want to use a pc.

What’s the best way to proceed to play with this thing?

I need to be able to upload some code to it.

solved it myself → http://www.jasinski.us/cheap-arduino-clone-dccele-dccduino-un

Start with Loopback test, see if CH430x driver is working.

Hello.

I recently found this site https://codebender.cc, and I downloaded the drivers that made my Nano work on Mac OS 10.11.1.

Dig up and give it a try. Use Chrome because Safari is not supported.

Cheers!

everyone got their El Capitan working with Arduino? why there's no update on the solution? I got a ProtoSnap and can't get anything working...

There seems to be a new SIGNED driver from the official source dated 3-Nov-2015. See http://kiguino.moos.io/2014/12/31/how-to-use-arduino-nano-mini-pro-with-CH340G-on-mac-osx-yosemite.html

I tried it and it works on El Capitan!!! Need to Option-Open the package to make it run.

Also found found I needed to select some other board then reselect Nano to get the correct port options (/dev/cu.whcusbserialNNN) to show up.

Arthur500: There seems to be a new SIGNED driver from the official source dated 3-Nov-2015. See http://kiguino.moos.io/2014/12/31/how-to-use-arduino-nano-mini-pro-with-CH340G-on-mac-osx-yosemite.html

Works fine with El Capitan (OS X 10.11 (15A284)), IDE 1.6.5 and NodeMCU 1.0 (CH340). Cannot test with Arduino as I have no Arduino with CH340.

Thanks for the link

I had problems until I inserted a usb hub between my iMac (el Capitan) and my original ardunino Uno and now it's working.

Each time I tried to upload a sketch, cpu goes to 100% and I was not able to open serial monitor

Now, with the usb hub, I can open the serial monitor, compile and upload sketches without troubles.

On the Mac console windows , the only difference is I don't see anymore the following message : AppleUSBHostPort::resetGated: retrying enumeration in 100 ms

I hope this will help someone

I have noticed lots of action on fixing problems with the Arduino IDE, but with the latest hourly build from Jan 11, 2016, I cannot download software to a real Arduino UNO rev 3 from the IDE on a Mac running El Capitan, and when I try I lose the Bluetooth connection to my keyboard and mouse.

While I realize that this was caused by changes made by Apple, I am disappointed that no fix has been made as yet. The problem is now several months old.

I have a very poor work around, running the IDE under a VM, so I am not out of business.

If someone tells me how to get diagnostic info I would be happy to do that.

No luck with El Capitan for me either. I am running Arduino IDE 1.6.7 and have a Zero board purchased from Arduino.cc. Only port option showing up is "/dev/cu.bluetooth-incoming-port".

I did.. You have to download this driver:

http://0xcf.com/2015/03/13/chinese-arduinos-with-ch340-ch341-serial-usb-chip-on-os-x-yosemite/

but you don't have to follow the instructions, these works with El Capitan, so:

  • Download the driver.
  • Install the driver, I insalled it from the pkg.
  • Reboot your mac in safe mode (Command + R while booting).
  • Open terminal and disabple System Integrity Protection: kext-dev-mode=1 (deprecate), it works with "csrutil disable". And reboot.
  • On startup check your SIP: "csrutil status", if it show Disabled you are ok otherwise back to pt 3.
  • Now this (I don't really know if it's strictly required):
  • sudo ln -s /dev/tty.wch\ ch341\ USB=>RS232\ 1410 /dev/tty.wch*

Now everything should works, at least it works for me. :D ;)

Hi,

I've the same problem with a fresh install of El Capitan on a Mac Mini. So I've found a workaround which is not the best solution, but it works.

On my MacI've installed Virtualbox https://www.virtualbox.org and its virtual box extension pack. Then I've installed Windows 7 on the virtual machine, the Arduino software, set up the configuration, drivers, ... It took a long time for the completion but now I could use again the Arduino on the Mac.

Cheers

I had the same problem. I found a signed version of the driver that solved the problem for me:

No joy here. I have an out of the box official Arduino Uno R3, the latest version of the Arduino app (1.6.8 Hourly Build 2016/02/02 running on a Mac with the latest version of El Capitan), and I've selected the proper board (Arduino Uno) and serial port (in my case /dev/cu.usbmodem141111 (Arduino Uno/Genunio Uno ). I'd tried disabling SIP, but still nothing.

When uploading, I get the dreaded

avrdude: stk500_recv(): programmer is not responding

I've been searching forums for almost two hours, and no one seems to have a solution.

Has anyone yet been successful?

I have been having that problem all day