ERR: Cannot find ameba on mbed driver! Please re-plug Ameba

I hope that this is the proper group for this problem.

Just got several RTLDUINO from eBay(http://www.ebay.ca/itm/Wireless-RTL8710-WiFi-Transceiver-Module-Test-Development-Board-for-Arduino-/322351146135?hash=item4b0da02497:g:LvUAAOSwEzxYRraP). I cannot flash them using the Arduino IDE. I would like to be able to. Here is my experience.

I downloaded mbedWinSerial_16466.exe from Ameba ARDUINO: Getting Started with RTL8710 – Realtek IoT/Wi-Fi MCU Solutions. I got the message that “The driver could not be installed. No mbed Microcontrollers were found.” I am using Windows 10, and found on further searching that this did not matter as the CH340 drivers were already present in Windows 10.

So, I selected the “Ameba RTL8710” and the proper COM port, then tried to upload the “Blink” program to my RTLDUINO. I got the message, “ERR: Cannot find ameba on mbed driver! Please re-plug Ameba.”. I tried to replug the unit several times with no good result. I tried three different USB cables on two different computers. I am using Arduino 1.8.1. I even tried selecting, “Ameba RTL8195A”, with no success. Through all this the Device Manager indicated that the unit was on “USB-SERIAL CH340 (COM4)”.

When I opened the serial monitor and set the baud rate to 38400 and pressed the reset button on the RTLDUINO, there was a whole screen of output, so I know that the unit is working. I tried both of my units.

ROM Version: 0.3

Build ToolChain Version: gcc version 4.8.3 (Realtek ASDK-4.8.3p1 Build 2003)…

WIFI initialized

init_thread(53), Available heap 0xc840

AT_UART_CONF: 38400,8,1,0,0

RTL8195A[HAL]: ISR 81 had been allocated!!!

[GPIO Err]HAL_GPIO_Irq_Init: GPIO Pin(0) Unavailable

The only answer to this problem that I could search out was to try replugging the Ameba board. This did not work. Is anyone else out there suffering this problem? Did you find a remedy?

Hi, I also got same problem and fixed it by updating the DAP firmware. There are instructions on How to update DAP Firmware? – Realtek IoT/Wi-Fi MCU Solutions