Erreur de compilation

Bonjour à tous,
je tourne en rond et j’ai besoin de vous :confused:
J’utilise un Arduino Nano et je souhaite simplement contrôler un servo moteur sur A0.
Rien de bien compliqué mais peut-être que ma version est obsolète !
J’ai installé Ardublock via Arduino Augmenté mais j’ai des messages ne me permettant pas de téléverser.

Il semblerait que mon Servo.h ne soit pas le même !??!

Voici le code généré :

#include <Servo.h>
Servo servo_pin_A0;
void setup()
{
  servo_pin_A0.attach(A0);
}

void loop()
{
  servo_pin_A0.write( 90 );
  delay( 500 );
  servo_pin_A0.write( 0 );
  delay( 500 );
  servo_pin_A0.write( 180 );
}

Voici l’erreur rencontrée :

In file included from sketch_jan23a.ino:1:
C:\Users\moi\Documents\Arduino\libraries\src/Servo.h:67:2: error: #error "This library only supports boards with an AVR or SAM processor."

Merci d’avance

le message d'erreur donne à pense que tu n'as pas sélectionné le bon type de carte. Pour en savoir plus il faudrait éventuellement aller dans les préférences et activer les "résultats détaillés pendant la compilation".

Merci pour ta réponse, voici ce que j'obtiens

C:\Program Files (x86)\Arduino\tools\ArduinoAugmente\arduino-augmente_BETA_0.55\hardware\tools\avr\bin\avr-g++ -c -g -Os -Wall -fno-exceptions -ffunction-sections -fdata-sections -mmcu=atmega328p -DF_CPU=16000000L -MMD -DUSB_VID=null -DUSB_PID=null -DARDUINO=105 -IC:\Program Files (x86)\Arduino\tools\ArduinoAugmente\arduino-augmente_BETA_0.55\hardware\arduino\cores\arduino -IC:\Program Files (x86)\Arduino\tools\ArduinoAugmente\arduino-augmente_BETA_0.55\hardware\arduino\variants\eightanaloginputs -IC:\Users\moi\Documents\Arduino\libraries\src C:\Users\moi\AppData\Local\Temp\build7323797643744387992.tmp\sketch_jan23a.cpp -o C:\Users\moi\AppData\Local\Temp\build7323797643744387992.tmp\sketch_jan23a.cpp.o 
In file included from sketch_jan23a.ino:1:
C:\Users\moi\Documents\Arduino\libraries\src/Servo.h:67:2: error: #error "This library only supports boards with an AVR or SAM processor."

Ce qui est épatant c'est que j'ai exactement le même message avec une Carte Uno

C:\Program Files (x86)\Arduino\tools\ArduinoAugmente\arduino-augmente_BETA_0.55\hardware\tools\avr\bin\avr-g++ -c -g -Os -Wall -fno-exceptions -ffunction-sections -fdata-sections -mmcu=atmega328p -DF_CPU=16000000L -MMD -DUSB_VID=null -DUSB_PID=null -DARDUINO=105 -IC:\Program Files (x86)\Arduino\tools\ArduinoAugmente\arduino-augmente_BETA_0.55\hardware\arduino\cores\arduino -IC:\Program Files (x86)\Arduino\tools\ArduinoAugmente\arduino-augmente_BETA_0.55\hardware\arduino\variants\standard -IC:\Users\moi\Documents\Arduino\libraries\src C:\Users\moi\AppData\Local\Temp\build7323797643744387992.tmp\sketch_jan23a.cpp -o C:\Users\moi\AppData\Local\Temp\build7323797643744387992.tmp\sketch_jan23a.cpp.o 
In file included from sketch_jan23a.ino:1:
C:\Users\moi\Documents\Arduino\libraries\src/Servo.h:67:2: error: #error "This library only supports boards with an AVR or SAM processor."

Petite question côté drivers ... je n'ai pas un drivers à installer pour les cartes ? ça expliquerait pourquoi il semble n'en vouloir aucune mon compilateur :-(

Que ce soit la nano ou la Uno cela fonctionne en ligne de commande, j'ai testé avec un environnement Arduino pur version 1.6.5