Error compiling for board Arduino/Geniuno Uno

I keep getting "error compiling for board Arduino/Genuino Uno" when I try to do the initial task for communicating with Arduino Uno on setup.

I found one other topic that said I should go into Boards Manager and change Arduino AVR Boards from it's current installation to version 1.6.11, which I have done, but this has not made a difference.

The error that is coming up is:

Arduino: 1.8.10 (Mac OS X), Board: "Arduino/Genuino Uno"

dyld: Symbol not found: _unlinkat Referenced from: /Applications/Arduino.app/Contents/Java/arduino-builder Expected in: flat namespace

/Applications/Arduino.app/Contents/Java/arduino-builder returned 133

Error compiling for board Arduino/Genuino Uno.

This report would have more information with "Show verbose output during compilation" option enabled in File -> Preferences.

If anyone can help I would be so grateful.

Thanks Laura

If anyone can help I would be so grateful.

Well how about helping us to help you.
Post your code and we might just stand a chance to find out where you have gone wrong.
Please use the </> icon on the top row far left and paste your code between the tage that pop up.

/*
  Blink

  Turns an LED on for one second, then off for one second, repeatedly.

  Most Arduinos have an on-board LED you can control. On the UNO, MEGA and ZERO
  it is attached to digital pin 13, on MKR1000 on pin 6. LED_BUILTIN is set to
  the correct LED pin independent of which board is used.
  If you want to know what pin the on-board LED is connected to on your Arduino
  model, check the Technical Specs of your board at:
  https://www.arduino.cc/en/Main/Products

  modified 8 May 2014
  by Scott Fitzgerald
  modified 2 Sep 2016
  by Arturo Guadalupi
  modified 8 Sep 2016
  by Colby Newman

  This example code is in the public domain.

  http://www.arduino.cc/en/Tutorial/Blink
*/

// the setup function runs once when you press reset or power the board
void setup() {
  // initialize digital pin LED_BUILTIN as an output.
  pinMode(LED_BUILTIN, OUTPUT);
}

// the loop function runs over and over again forever
void loop() {
  digitalWrite(LED_BUILTIN, HIGH);   // turn the LED on (HIGH is the voltage level)
  delay(1000);                       // wait for a second
  digitalWrite(LED_BUILTIN, LOW);    // turn the LED off by making the voltage LOW
  delay(1000);                       // wait for a second
}

Thanks for the code box. That compiles fine for me using the IDE 1.8.10

You could always try reinstalling it.

I tried reinstalling Arduino completely and still having the same issue. Not sure what else to try

Is this a genuine Arduino or a cheap Chinese fake? If it is a fake you will have to install extra USB drivers.

I bought it from the RS Components so hope it is not a fake...

See this thread: https://forum.arduino.cc/index.php?topic=639200.0

Thanks MrMark. I will give it a go and let you know how I get on

MrMark: See this thread: https://forum.arduino.cc/index.php?topic=639200.0

That worked perfectly. Thank you MrMark

I Worked for hours looking for drivers. This answer safe my life LOL

I Just downloaded the old version of Arduino and everythink is working good.

Thank you, guys!