Error uploading in pro mini arduino Atmega328p 5v 16MHz

Somebody can help me with this? I tried in many ways. I already do downloads of one "breadboard" that I saw in ide forum but still keeps giving errors. I took some screenshots of the attempts I made and put in front of the errors that were shown. All thoes seems like this:


Sometimes the problem is "programmer is not responding" and sometimes is "uploading to board". Any help?
This is the "breadboard" that i downloaded but it just not helping me.
breadboard-1-6-x.zip (3.0 KB)

Errors:




The first thing you need to understand is that the Tools > Programmer menu selection is only used when you are doing Tools > Burn Bootloader or "Upload Using Programmer". When you're doing a standard "Upload", the Tools > Programmer menu selection is completely ignored. So it makes no difference at all what you have selected from the Tools > Programmer menu. I see you are getting fixated on that menu selection due to the upload error message's mention of a programmer, but this is not relevant to your problem.

You should also not be using that "breadboard" thing. Just leave the Arduino menu selection on Tools > Board > Arduino Pro or Pro Mini.

Please tell us about your Pro Mini. These boards don't have an on-board USB adapter, so it's necessary to connect a separate one. We need to know about what you are using and how it is attached to the board.

So, I'm using this:



I saw like that in internet, but I also tried with my arduino uno.

Maybe auto reset is not working. Try manual reset for sketch uploading.

By the plate button? I tried it but it didn't work. Do you have any other options?

The tricky thing is that when you press the "Upload" button in the Arduino IDE, it first compiles your sketch before starting the actual upload. So you need to wait until after the compilation finishes before pressing the reset button. The way to get the timing right is to watch the black console window at the bottom of the Arduino IDE window. As soon as you see something like this:

Sketch uses 444 bytes (1%) of program storage space. Maximum is 30720 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.

press and release the reset button.

I tried right now and it's failed. But I tried in arduino create online in this time (I don't know if this make any difference) and this was the error:
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x89

I don't know more what I have to do.

Are you sure USB2TTL works? If you are not, you can test it easily.

Wiring like on picture and do loopback test.

I will not lie, I'm not sure about it but I tried send the code ifmy Arduino Uno too and got me the "same" error.

Do you have the proper driver for you usb to ttl board? (sorry if this is a repeat)

Have you tested on another computer?