ESP8266 AT command is not working through andrino uno

Hi,

I am trying to connect ESP8266 via andrino uno while checking serial monitor. It showing blank.

Please find configuration:

Andrino TX → ESP8266 RX
Andrino RX → ESP8266 TX
Andrino 5v → I have made power supply model using capacitor and regulator 3.3 v → VCC and CH_PD
Power supply model GND → ESP8266 GND
Also i have tried Andrino GND → ESP8266 GND

I have attached the model.

Wifi is detecting but none of the AT commands are working.

Hope you could help me.

Thanks
Pramod

Which Arduino?

Which ESP8266 module?

.

For the hardwired serial pins it is Tx to Tx and Rx to Rx.

It looks like you are using an Uno and Esp-01

Thanks. Yes Arduino Uno and esp01 is the model. I already tried TX to TX and rx to rx ... still no success ..

http://www.martyncurrey.com/arduino-to-esp8266-serial-commincation/

What is that voltage regulator you are using?

It does not look like an ams1117. The ams1117 is tiny, that looks huge.

Read Martyn Currey's blog as suggested, you can try the 3.3v pin on the Uno, but it is preferred esp-01 have its own power supply.

115200 default baud rate
both NL and CR on serial monitor

And Tx to TX, Rx to Rx for hardwired serial, pay more attention to arrows on Uno than the labels

Its 1117 not AMS but different brand. I have checked the V with the help of digital multimeter and power show is 3.3 v.

Let me try adding 10K resistors to TX pin because arduino is 5v and ESP8266 is 3.3v.

you only need the voltage divider on the Arduino TX pin. The 5V Arduino will read 3.3v as HIGH so you can connect the ESP8266 TX pin directly to the Arduino RX pin.

I have put 2K ohm between TX ESP8266 to TX Arduino. Still AT is not working and i am not able to upload code.

Error code:
warning: espcomm_sync failed
error: espcomm_open failed
error: espcomm_open failed

attached pics for design.

Thanks
Pramod

That’s not how you make a voltage divider.

If you cannot figure it out, I suggest you order some of these handy things from ebay.

Google 5v to 3.3v TTL voltage divider
s-l1600.jpg

and
Error code:
warning: espcomm_sync failed
error: espcomm_open failed
error: espcomm_open failed
why are you trying this? I thought you wanted AT commands. For that you don’t even need the arduino IDE

I also have same trouble i am using arduino uno, AMS 1117 3.3V Regulator, esp is working but not replying any commands i think something problem with a firmware its esp8266-01 2013 Model

did the problem solved sir...as i started facing the same..someone help