FDX-B 134.2 kHz RFID reader

Thank you. Here is your table for RFID.


Which antenna do you have?

It is 97mm x 97mm (square).

Hmm okay, It says ;
Use length 97x 97mm square antenna reading card distance are as follows

2x12mm glass tube is about 18CM

The diameter of 3CM ear tag reading distance is about 36CM

To tune it I need to be able to confirm the current that it is drawing... but unfortunately the multimeter I have does not seem to be any good at measuring current. I'll be keen to hear what distance you get with the ear tags.

Thank you, first I will try my rifd reader with high impedance ,3600 ohm as I calculate. If I couldn't have 35 cm read range, I will buy this , I think this is yours RFID. I will buy 100mm square antenna.

Hi again, I am having 28cm. I just want you to say it :slight_smile: . Maybe I will try to make 240x380 mm antenna for more distance.

awesome!

Hey @red_car - I've got the same RFID reader, but can't seem to get it working on my ESP8266 (NodeMCU). I can't tell if my RFID reader is DOA, or if I've got something wrong with code/connections/etc.

Can you tell me if the RFID reader gives any sort of physical indication of reading a tag, or even send any garbage data over TX at power on? Anything that would indicate it's actually reading. I get nothing over serial (even with a 3.3v->5.5v TTL signal converter for my NodeMCU).

It does seem to draw 87mA from my power supply, so I feel like it's alive, I just can't get any output from it. :frowning_face:

Thanks!

Can you post a pic of your set up?

As for a physical indication... there is a small blue LED that momentarily lights up when a chip is read... in the corner by the crystal. As in this video. http://cloud.video.taobao.com/play/u/2675628091/p/1/e/6/t/1/250532881243.mp4

Nothing over the TX line at startup from what I can see.

What are you powering it with? Needs 5 - 9 v as per the spec sheet that came with it.

@red_car - Attached are 2 pics of my setup.

Ideally, I'll be feeding the RFID board 5v (measured at 4.925v), but also tried feeding it 6v and had the same lack of action. I've tried a couple different power supplies (PC-USB, LiPo USB battery, bench DC power supply) so I would think at least one of those should have been low enough noise since the docs mentioned power noise sensitivity.

The only oddity I'm wondering about is the header plug I soldered to the ANT coil so I could remove it during testing. Would that cause issues?

Note: the white heat-shrink are wires I soldered together for a solid multi-pin connection.

Bit hard to see all the connections. Have you tried taking the level shifter out of the mix... so just run 5v and GND to the reader. In the video, there is nothing connected except a battery.

What are you testing it with?

TL;DR - My test chip apparently isn't compatible with this board, real cat implanted chips are OK though.

@red_car - so I was testing with One of these collar chips from SureFlap. They are compatible a different RFID chip cat feeder system that didn't work for my case, hence why I'm rolling my own setup.

Sure enough, when I tried it on one of our real cats, the little LED on the RFID board lit up. Apparently the other system can read the 134.2 kHz chips, as well as whatever frequency these collar based SureFlap branded chips run at. Seems odd they wouldn't keep them the same just for simplicity sake.

I'll try checking my code to verify that I get data over serial now, but this is the first reaction I've gotten from the board.

To answer your other question, I did try without the level shifter, but had same results. I should be able to tell over the next couple days if the shifter is needed once I validate the code to read the serial data.

I feel like a dummy for not trying on the cats earlier, I just assumed compatibility with my spare chip, which wasn't the case :frowning_face:

Nice @nullrequest ... glad to hear it's working.

I only had our cat to test mine on and luckily it worked first time :slight_smile:

I've been using the code posted earlier in the thread without any issue. I was little concerned at first as the country code wasn't what I was expecting (New Zealand). But after a bit of research it seems the 900 range is user defined... and in my case 982 is a particular chip manufacturer.