Fingerprint Sensor DY50 Arduino UNO not working.

Hi!

I bought a fingerprint sensor to use it with my UNO. And despite of the fact that I have follow dozens tutorials I couldn’t make it work.

Finally, I decided to try every wiring posible, you can check it in pictures.

I used adafruit code:

/*************************************************** 
  This is an example sketch for our optical Fingerprint sensor
  Designed specifically to work with the Adafruit Fingerprint sensor
  ----> http://www.adafruit.com/products/751
  These displays use TTL Serial to communicate, 2 pins are required to 
  interface
  Adafruit invests time and resources providing this open source code, 
  please support Adafruit and open-source hardware by purchasing 
  products from Adafruit!
  Written by Limor Fried/Ladyada for Adafruit Industries.  
  BSD license, all text above must be included in any redistribution
 ****************************************************/

#include <Adafruit_Fingerprint.h>

// On Leonardo/Micro or others with hardware serial, use those! #0 is green wire, #1 is white
// uncomment this line:
// #define mySerial Serial1

// For UNO and others without hardware serial, we must use software serial...
// pin #2 is IN from sensor (GREEN wire)
// pin #3 is OUT from arduino  (WHITE wire)
// comment these two lines if using hardware serial
SoftwareSerial mySerial(2, 3);

Adafruit_Fingerprint finger = Adafruit_Fingerprint(&mySerial);

void setup()  
{
  Serial.begin(9600);
  while (!Serial);  // For Yun/Leo/Micro/Zero/...
  delay(100);

  Serial.println("\n\nDeleting all fingerprint templates!");
  Serial.println("Press 'Y' key to continue");

  while (1) {
    if (Serial.available() && (Serial.read() == 'Y')) {
      break;
    }
  }

  // set the data rate for the sensor serial port
  finger.begin(57600);
  
  if (finger.verifyPassword()) {
    Serial.println("Found fingerprint sensor!");
  } else {
    Serial.println("Did not find fingerprint sensor :(");
    while (1);
  }
  
  finger.emptyDatabase();

  Serial.println("Now database is empty :)");
}

void loop() {
}

And I always receive the same output “Did not find fingerprint sensor :(”

I don’t know what to do.

Thank you in advance. :slight_smile:

Finally, I decided to try every wiring posible, you can check it in pictures.

Which might have produced short circuits and damaged your Arduino and/or the fingerprint sensor. Start by checking if your pins 2 and 3 still work. Adafruit shows how the wiring should be done in it's tutorial.

Dear, I imagine that it should have already solved. If you haven’t already, I managed to make it work on Arduino Uno using pins 8 and 3 “SoftwareSerial mySerial (8, 3);”

The difficulty I am encountering is: when I transfer it to the arduino nano or pro mini, it doesn’t work even though I’m already testing various combinations of pins.

If someone has already gone through this and solved it, I ask for help.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.