FTDI FT232R not working - stk500_getsync(): not in sync: resp=0x00

I’ve spent many hours trying to get a simple sketch to transfer to a Arduino device via a FT232R device. (like many other people have) I actually tried with three different FT232R based cards on two different computers. One running XP the other running windows 8.

The three FT232R based cards:

  • 1st card was very flaky - Seemed like it had a bad solder connection on the USB port. Computer(s) would not see the FT232R device at times.
  • 2nd card (identical replacement card for the first) - No problem with the compute seeing the card/device.
  • 3rd card - different make then the 2nd card - Produced the same results/problem.

While waiting for 2nd/3rd card to arrive, I was talking to a friend and he happened to have a CP2102 based card. I borrowed the card from he, installed the drivers, made the board connections, did the manual reset during upload, and presto, I got the blink sketch to load. I then installed a temperature probe sketch which printed information out via the Serial port and it all works.

So my 2nd/3rd FT232R based cards arrive. I was thinking this should be easy… but guess what; I was back to the stk500_getsync(): not in sync: resp=0x00.

At some point along the way, it dawned upon me that my old sketch was still loaded and it was printing information on the serial port. So I opened up the Bray terminal program, connected to the com port, set the data to hex and what do I see coming back? <00> <00> <00> <00> delay <00> <00> <00> <00> delay <00> <00> <00> <00> … instead of (dec) 70 delay 70 delay …

I reproed the same results using either one of the two FT232R based cards… and I also moved the setup to a 2nd computer and got the same exact results. =(

If I go back and hook up the CP2102 based card, everything works great. The terminal program shows 70 delay 70 delay etc.

So for now I left scratching my head wonder why the FT232R based cards are not seeing the correct data from my Arduino device… and I do say the “correct data”… it’s very apparent that the card is seeing data, it’s just seeing all <00> data… or the data is being lost inside the FT232R device.

Any thoughts?

Thanks

Dean

Hi, I'm not sure if this is related directly or not. But I was getting same error in my Arduino Nano.

This is how I fixed it.

http://arduino.alt245.com.ar/how-i-dealt-with-this-error/

Hope that can help you...

Well, I'm still working on this. There seems to be a missing link between the USB port and the VCP? The outgoing data never makes it into the outgoing USB packet and the incoming data gets dropped between the USB packet and whatever is suppose to pick it up. (ie I see good data in the incoming USB packet but it never makes it to the COM port)

I'm still working with the kind folks at FTDI but as of yet, I still have not been able to convince them they have a 2.08.28 driver problem.

Today I decided to install "unsupported" driver version 2.08.24 and presto my ft232r chip is now able to send non-zero data to my com port. I did not try to upload a sketch yet but the old drivers are looking much better then the currently "supported" drivers.

I guess I should also note, on Windows XP I needed to directly point to the inf files to get the older version to install. Windows XP likes to keep the most recent drivers... so you need to be a bit persistent to ensure the older drivers get installed.

Thanks for this post. I purchased a FT232RL USB to Serial adapter module the other day and got this same error message when uploading; no matter what I tried. It had the driver 2.08.28 on it.

After updating (back dating?) to driver 2.08.24 from FTDI sketches upload to my MINI Pro as they should.

You should check out this thread, apparently there are some fake FTDI FT232RL chips out there: http://forum.arduino.cc/index.php?topic=173676.msg1311792#msg1311792