getting a handle invalid issue PLEASE HELP!

So I have been working on my folger ft-6 now for quite a while, the boards inside are a bigtreetech skv1.3 and a orange pi. When trying to upload my program it gives me this error message after the compiling stage

avrdude: ser_open(): can't set com-state for "\.\COM3"
avrdude: ser_drain(): read error: The handle is invalid.

Problem uploading to board. See for suggestions.

I am trying to run the marlin software modified for the folger tech ft-6 (definitely not the problem) using Arduino 1.6.9 if you have any more questions just ask :slight_smile:
I have been working on it for a while now, over 3 weeks and know it isn't the hardware itself nor is it the coding or a minor mistake in the coding. I am always willing to check out whatever you guys say might be the problem, thanks in advance. -Etherium-

Make sure you have selected the port of your printer board from the Tools > Port menu.

Sometimes the port will be labeled with the board name in the menu. Other times it will not. If you don’t know which port is your printer, you can find it like this:

  • Unplug your printer board from the computer.
  • Tools > Port
  • Note the ports, if any, listed in the menu.
  • Close the Tools menu
  • Plug your printer board into the computer.
  • Tools > Port - The new port listed in the menu is your printer board.

I tried that it appears to be the correct port

Try restarting your computer. Sometimes a glitch will cause a port to get stuck in an unusable state and the restart fixes that.

If you're getting that error, it can also imply a hardware or driver problem (I'd wager you would be unable to open the port in any application).

I vaguely recall one guy posting with a similar error, and it turned out that on some combination of windows version and other conditions, CH340G or CP2102 (forget which), which are commonly used on clone arduino boards instead of the 16u2 would, without drivers installed, create a COM port, but it would give this error when you attempted to use it. Downloading and installing the appropriate drivers fixed it.

As per noted, this can also happen when an application has left the port in a bad state (restart computer) or when hardware conditions (like a momentary short or power glitch) has caused the hardware to act in a way that confuses the computer (unplug and replug board, restart possibly also needed).