Help with NANO328 CLONE

New, out of the box; All I´ve done is connect to USB port, It´s recognized as a USB/Serial CH340 And functions correctly. I can see the 3 controller files in place.

It has 4 LEDs: Rx, Tx, Power and L ( BUILTIN LED? ) The power LED turns ON and the L flashes a few times as though resetting, then starts at about 1s rate, but I can´t upload, neither code or bootloader ( haven´t tried with OLD BOOTLOADER option ), don’t want screw anything. I suppose it has a bootloader, it´s flashing the BUILTIN LED because it´s programmed? My TOOLs options are OK; “Arduino Nano”, “Atmega328P”, “ArduinoISP” I uninstalled and reinstalled the drivers and Arduibo IDE 1.8.13, doesnt work What could be wrong

So why haven’t you tried the old bootloader option? It’s a different baud rate. Very likely the case on a clone Nano.

Are you aware that you cannot install a bootloader over the usb connection? You can only do that with an ISP programmer (Usbasp and Arduino as isp are two ways).

Will try and come back

To be absolutely clear, there is, generally speaking, nothing you can do to brick an Arduino with a USB download. The worst thing you can do is to download a non-working program.

Even disconnecting it from USB or having a power failure during a download should not bother it. They’re pretty robust.

If you ever think you bricked your Arduino, just download the Blink program from the IDE. If the built-in LED blinks, it’s working.

Thanks, sorry for late reply, dont have internet at home and it fails every now and then

tried with old bootloader and it works.