Hilfe alles weg

tag liebe leute!
ich habe mir vor einiger zeit eine blipbox gekauft das ding ist super, und macht alles midi mäßiges wie ich es möchte. da ich mich nur mit meinen synths drumcomputern und midi auskenne, dacht ich mir jetzt schau ich mir das ma an mit dem open source programieren. jetzt geht das ding nicht mehr und alles mist- ich brauchs ja für mein liveact.-war sehr sehr dumm von mir.
wenn hier irgend jemand ist der mir sagen kann wie ich das wieder original bekomme . dem bin ich sehr sehr dankbar.
ich hab mir jetzt auch ma so ein seinsteigerset gekauft um das ich versprech nich wieder mit so einer blöden bitte an euch trete.

http://blipbox.org/blog/
hier die seite von dem teil, ich kann mit der install von der firmware null dunst. danke im voraus . weis gar nich wie ich machen soll so ohne das teik live.

cheers
analog species

Was hast Du genau gemacht?

ich habe arduino gewöffnet und wollte ma schaun was mann so noch machen kann und da warscheinlich alles falsch gemacht. ich denke ich hab somit die firmware gelöscht. war wohl der meinung ich kanns schnell wieder orginal machen. momentan geht gar nichts. es reagiert zwar auf ein paar sachen die ich drauf kopiere, aber ich bekomme einfach die firmware nich drauf . das forum hier scheint für mich die letzte hilfe. naja wenn mann was am synth falsch macht, gibts halt ne feste software die mann einfach resetet, aber bei der box kann mann halt alles löschen und anderen blödsinn mit machen. für einige sicher geile sache, aber für mich war die originalfassung perfekt. um so mehr ärgert mich meine verdammte neugier. siehst du da eine möglichkeit? oder ist das gerät zu spezifisch?

Als was wird die blipbox im Gerätemanger erkannt?

Wie heißt das Programm genau das du verwendest/verwendet hast??

Hast Du diese Software schon mal versucht aufzuspielen:

https://github.com/pingdynasty/BlipBox/tree/master/src/Arduino/SquareWaveSynth

Falls das nicht die richtige ist, was konnte das Ding denn mit der originalen Software?

Ansonsten: Hast Du schon mal versucht mit dem Entwickler über das Blog Kontakt aufzunehmen?

also treiber passen. osx reagiert noch auf die box. ich hab e versucht die software ( firmware, was auch immer ) hoch zu laden, aber jedesmal mekert arduino rum , . wie( das ist ja nur eine variante ) :

BlipBox.cpp:1:22: error: WProgram.h: No such file or directory BlipBox.cpp:22:29: error: BlipBoxProtocol.h: No such file or directory BlipBox.cpp:23:34: error: MonomeSeriesProtocol.h: No such file or directory BlipBox.cpp:24:21: error: globals.h: No such file or directory BlipBox.cpp:25:18: error: defs.h: No such file or directory BlipBox.cpp:27: error: expected constructor, destructor, or type conversion before '*' token BlipBox.cpp:29: error: 'BlipBoxProtocol' does not name a type BlipBox.cpp: In function 'void setup()': BlipBox.cpp:35: error: 'INPUT' was not declared in this scope BlipBox.cpp:35: error: 'pinMode' was not declared in this scope BlipBox.cpp:47: error: 'protocol' was not declared in this scope BlipBox.cpp:47: error: 'blipboxProtocol' was not declared in this scope BlipBox.cpp: In function 'void loop()': BlipBox.cpp:53: error: 'protocol' was not declared in this scope BlipBox.cpp: In function 'int main()': BlipBox.cpp:57: error: 'init' was not declared in this scope

ich glaub echt das problem ist auf meiner seite, das ich nicht fähig bin ein programm hoch zu laden. die box funktioniert auch standalone , aber die funktion ist ja ganz tot,- also ich glaub wenn ich ne erklärung für ganz dumme bekomme schaff ichs, hehe. selbst tutorials helfen grad nich. die box steuert viele cc/ note midi signale die man über blipzonesoftware einstellen kann und speichern. an sich hab ich nur mit arduino rumgespielt aber das hat ja alles zêrstört, ich bekomm wie gesagt durch andere progs ne reaktion, aber ich will unbedingt wieder standard. vieleicht hat ja einer ne tool oder die möglichkeit mir den weg zu weisen .

aspecies: BlipBox.cpp:1:22: error: WProgram.h: No such file or directory ... ich glaub echt das problem ist auf meiner seite, das ich nicht fähig bin ein programm hoch zu laden.

Bei der angezeigten Fehlermeldung ist Dein Problem zunächst einmal, dass Du versuchst einen alten Arduino-Sketch Quellcode auf einer neuen Arduino-Software zu kompilieren. Und das schlägt fehl, weil es mit der Compilerversion 1.0 größere Umstellungen an der Arduino-Software gab, die an Code für ältere Versionen oftmals mehr oder weniger große Änderungen erfordert.

Installiere Dir mal für Deinen alten Quellcode eine alte Version der Arduino-Software, z.B. 0023 oder 0021, und kompiliere Dein Programm damit! Wenn es sich kompilieren läßt, dann läßt es sich bestimmt auch hochladen.

ich muss echt ein wenig beschränkt sein. kann das sein das ich da noch was einschreiben muss ? müssen die daten ein bestimmten file haben? ich bekomme nich ma ein wenig hochgeladen. isch dreh durch . :-(

Wenn man nicht auf alle Fragen antwortet, sondern anscheinend nur den letzten Post beachtet, dann bekommt man vom Rest natürlich auch keine Hilfe mehr.

Ich vermute mal die Sache wäre schon längst gegessen, wenn du dir nicht so viel Zeit zum Antworten lassen würdest, und auf ALLE Posts und ALLE Fragen eingehst. Das macht auf mich einen sehr chaotischen Eindruck.