Hybrid Stepper Linear Actuator vibrating but not moving

I'm working with a friend on a project and our bipolar hybrid stepper motor linear actuator is just vibrating and whining without moving. We've got our Arduino UNO connected to the driver which is connected to a TW6050A variable DC power source, supplying 2.5V according to the linear actuator's specs. We've tried checking connections, re-arranging the pins, and lowering the voltage but no change no matter what we do, other than the pitch of the whine lowering or raising.

Neither of us have much Arduino experience but after researching similar issues none of the proposed solutions we were able to find worked for us.

Linear actuator: 21H4U-2.5-915 Size 8 Hybrid Stepper Linear Actuator by Haydon Kerk Motion Solutions https://prototypes.haydonkerk.com/ecatalog/hybrid-linear-actuators/en/linear-actuator-21H4U-2.5-915

Driver: DRV8834 Low-Voltage Stepper Motor Driver Carrier https://www.pololu.com/product/2134

Thanks!

TClark13: supplying 2.5V according to the linear actuator's specs.

This is your mistake.

Stepper motors are driven by current, not voltage. Try the highest voltage that your driver will allow and adjust the current limit on the driver to 0.49 amps so as to protect your motor.

For even better performance use a driver that can work with higher voltages - such as a Pololu A4988 or DRV8825

...R Stepper Motor Basics Simple Stepper Code

Yep dumb mistake on our part that worked thanks!