I can`t install Adafruit library for oled display

Hello I have a problem.
I am new to arduino and want to use a 1.3" oled display to just display somthing.
I watched some tutorials on how to use one and installed the Adafruit GFX and SSD1306 library but I can´t install it.
I always get this error:


I would love to get some help.

Welcome to the forum

Please follow the advice given in the link below when posting code, in particular the section entitled 'Posting code and common code problems'

Use code tags (the </> icon above the compose window) to make it easier to read and copy for examination

Implies you have installedthe library (first.)

https://www.arduino.cc/en/guide/libraries

Have fun.

That`s my problem I have installed them and it does not work.

What about the library that the error message says it can't find ?
Is that installed ?

Yes I tried diferent fersions and reinstalled both of them in diferent ways 10 times. :frowning:

Restart the IDE and see if that works. If you installed them properly, they can be found by browsing in file explorer to ...\Arduino\libraries\

If the library(s) were installed correctly and the ArduinoIDE still cannot find the code, your environmental pathing may be corrupted; can happen rarely for various reasons but just reinstall the Arduino application.

Didn´t work I got the same error.

Windows 10 or Windows 11?
Latest Arduino version for Windows?

Try this:

  1. Select Sketch > Include Library > Manage Libraries... from the Arduino IDE menus.
  2. Wait for the update to finish.
  3. In the "Filter your search" field, type Adafruit BusIO.
  4. Press Enter.
  5. Scroll down through the list of libraries until you see "Adafruit BusIO by Adafruit". Click on it.
  6. Click the Install button.
  7. Wait for the installation to finish.
  8. Click the Close button.

Now try uploading your sketch again.

I am using 10 but I am tying a new arduino version now

? I assume this is necessary because of the Adafruit major rewrites? P.I.T.A. but who does not use at least something from Lady ADA?

Here is the way things should appear in Win-10/11:

Adafruit has done a major software re-architecture on how the low-level SPI/I2C etc work, so even when your sketch calls 2 libraries, other libraries may be dependent. In a perfect world, library manages should keep this synchronized.

But, I do not use libraries this way. All libraries I use are located in each sketch folder ... Yes, lots of duplicates but when I Zip-up a folder for archive or sharing, I know that it will work again pending IDE and GCC concerns.) This also allows me to hack (frequently) the project confined library without mucking with the always-updated master copy in \libraries.

Thanks it is gone now but I have a new problem I cant see anything on the display?

No, it is necessary because an upload is what I assume @loooool was trying to accomplish when they were interrupted by the compilation failure that was caused by them not installing the library dependency. Note that the Upload button is activated in the screenshot.

If you don't want to upload the sketch to your board, then don't, but installing an Arduino library doesn't do you much good if you never use it in a program on an Arduino board.

Always test with example code (esp. Adafruit libs.)

:joy:

But it happens ALL the time here in the forums!
I think a large portion on Arduino'ites grab every library they can find ... "just in case" ... you know, global inflation is causing even Free-Open-Source code to become more expensive.

Ray

2 Likes

Thank you guys it was a great support. :slight_smile: