I really don't want to update the firmware in my ESP8266-01. Do I have to?

I'm hoping that someone will point me in the right direction. I've been trying to get an ESP8266-01 working. Many demonstrations go directly to upgrading the firmware. Wait, slow down a little. Who says I need to update the firmware. All I want is to test the basic AT communication first, to find out the version, and to make sure the device is working as advertised. And in the end, I will be using this device only with AT commands anyway. So why does everyone going straight to updating the firmware?
Even if I decided that I do want to update the firmware, shouldn't the basic AT commands be working first, in order to prove that the unit is working? Someone please explain a little something to me.
I can provide any details that anyone needs to help.

I've never seen a tutorial that tells you to go straight to updating the firmware. I would definitely start by using whatever version of the AT firmware that is already on your board. The firmware update process can be very confusing and problematic. I've been using ESP8266 for years and I still have trouble with it.

That is exactly what I'm trying to do. When I apply 3.3 v power, the Red led turns on and the Blue led flashes briefly, then goes out. Observing the Serial Monitor, either Arduino's or Cool Term, I get the standard line of gibberish, followed by a blank line, followed by, Ready. I type in: AT and I get nothing in return. I am using a USB to TTL serial converter, with 1k + 2k voltage divider from the Tx of the converter to the Rx of the ESP8266-01. I did not try to use the Arduino Uno as an interface because I didn't want to run the risk of uploading anything to the ESP8266-01, only the USB to TTL Converter and only AT commands from the Serial Monitor.

I just found something interesting that I read on another Arduino forum post from Juraj. He said to try something that I had never read about before. In reply #20, this morning at 3:07 AM he said,

"open Serial Monitor on COM port of the Uno/esp8266, set the baud rate to 74880 and reset the esp8266 by disconnecting the CH-PD and connecting it back. you should see the bootlog of the esp8266. then try the same with 115200 baud. you should see the startup prints of the AT firmware"

I had never read that disconnecting and reconnecting the CH-PD pin of the ESP8266-01 was another way of resetting the ESP8266-01, and would return the bootlog at 74880 baud. Then setting the baud to 115200 and again resetting by removing power from CH-PD would return the startup prints of the AT firmware. I've never heard of "startup prints of AT firmware, but I was surprised to see that although it still returned gibberish, the gibberish was different. I tried my AT and to my pleasant surprise , got OK back. I noticed also something else that I thought curious, that what gets placed on the serial monitor when pressing Reset is different from what I see by removing and returning power to CH-PD. Now to see if I'm pushing my luck with some other AT commands.

I have been following this thread in earnest since I have my own thread with a similar problem. I would sure like to know if michaelb33 found resolution to his problem, since I am having a very similar issue going on. My setup differs from his though, in that, I am using a buck converter that I have adjusted to 3.4 volts, that seems to be supplying the voltage just fine. I was using the Cool Term terminal program and was surprised to find that it doesn't have a 74880 baud rate setting. I switch to using the Arduino IDE Serial Monitor set it to the 74880 baud rate and was very surprised to see what came up upon reset. And when I change the baud rate to 115200 baud, I finally did get an OK response from my AT sent. But...
I went to gather my thoughts about the next thing that I wanted to do, and when I returned an hour later, when I entered AT, I got nothing back. I went through the same routine of switching baud to 74880, doing a reset, returning the baud to 115200, sending AT and got OK back.
What is going on here? It seems that I can't count on it to continue working over time.

Do you have the line ending menu of Serial Monitor set to "Both NL & CR"?

Thank you pert. Yes I do have both NL & CR set to be added to any command that I send. I don't believe I would get anything back at all if I didn't have them set. This issue that I'm seeing seems something of a, hit and miss. Why would:

  1. Changing the baud rate to 74880.
  2. Removing and Replacing power from the CH-PD pin.
  3. Changing the baud rate to 115200.
  4. Resetting the unit by grounding the Reset pin.
  5. Receiving the:

sdvp;kladfnvsdvkoaejrviopaerjkv
Ai Thinker Technology Co LTD

Ready

  1. Then have good responses from AT commands, But only for a while.

Returning an hour later, without changing anything. The setup is completely unchanged and finding it totally unresponsive. However, if I repeat the above steps, it works again.

it could be that the USB port is put to sleep by OS

Thank you Juraj for your response. On another project that I was working on a while back, I was using Cool Term, terminal program to to save some data to a text file. It worked great, until I walked away. I had Cool Term put a time stamp on each row of data as it was being received and saved into the text file. Later when I went back to check on the running of the project and the data being saved, I found that the computer screen was black. It had gone to sleep. When I later reviewed the text data file, I saw that it only saved data for as long as it took to match my sleep settings. So I turned off all of the sleep settings and was able to save the data for as long as I had my laptop there and Cool Term running.
Since that time, I have not changed my sleep settings. I left them off. So the answer is, no, there are no sleep settings on this laptop causing that.
Yesterday afternoon I went out for several hours. Before I left I sent AT, several times, and got OK back every time. I also tried AT+CWLAP, and got the word, error. When I returned, 3 or so hours later, I went straight to the project and checked AT, again, and it worked. AT+CWLAP again returned, error. I also sent AT+CWMODE?, and received back CWMODE=2. Next I sent AT+CWMODE_DEF=3
This morning I haven't setup the laptop to the project out in the garage yet, but I thought that I'd check this forum before I did. Any other thoughts? Stephen