I2C device not found

Hello, everyone. This is my first post in this forum. Sorry if I broke some of the rules.

Moving to the main thing. Not long time ago I bought a “Blue Serial IIC/I2C/TWI 2004 204 20X4 Character LCD Module Display For Arduino” from Ebay. In the internet I found out that it is possible to connect LCD to my arduino board through the I2C that is located on the back side of LCD. Found a code on the internet to display text to LCD, tried to use it- the text were not displayed. After a while found out that each I2C uses different address(0x27 didn’t worked). So I’ve ran several “I2C scanners”. None of them could detect the device.

I have no idea what culd be wrong. Could use some help. Thanks.

The wires are connected:
GND<->GND
5V<->VCC
A5<->SDA
A4<->SCL

Here are some pictures:

A4, A5 are the Uno I2C pins You have a MEGA2560.

SCL, SDA are at the bottom left of the photo you posted. (there is a second place for SCl, SDA at the bottom right of your photo)

It does not matter which SCL, SDA you use.

David.

Pradedantysis:
The wires are connected:

A5<->SDA
A4<->SCL

Even if you had a Uno, those are back to front.

David and Elvon, thank you a lot. Coudn't notice that on my own. Everything works perfectly now. :)