IDE 1.6.2, Avira reports virus TR/Crypt.XPACK.Gen several times

I just installed the version 1.6.2 on Windows 7. Avira finds TR/Crypt.XPACK.Gen in the following files:

Die Datei 'C:\Users\Mathias\AppData\Roaming\Arduino15\packages\arduino\tools\avr-gcc\4.8.1-arduino2\avr\bin\ld.exe' enthielt einen Virus oder unerwünschtes Programm 'TR/Crypt.XPACK.Gen' [trojan].

In der Datei 'C:\Users\Mathias\AppData\Roaming\Arduino15\packages\arduino\tools\avr-gcc\4.8.1-arduino2\bin\avr-ld.exe' wurde ein Virus oder unerwünschtes Programm 'TR/Crypt.XPACK.Gen' [trojan] gefunden.

In der Datei 'C:\Users\Mathias\AppData\Roaming\Arduino15\packages\arduino\tools\avr-gcc\4.8.1-arduino2\bin\avr-objdump.exe' wurde ein Virus oder unerwünschtes Programm 'TR/Crypt.XPACK.Gen' [trojan] gefunden.

In der Datei 'C:\Users\Mathias\AppData\Roaming\Arduino15\packages\arduino\tools\avr-gcc\4.8.1-arduino2\bin\avr-ld.bfd.exe' wurde ein Virus oder unerwünschtes Programm 'TR/Crypt.XPACK.Gen' [trojan] gefunden.

In der Datei 'C:\Users\Mathias\AppData\Roaming\Arduino15\packages\arduino\tools\avr-gcc\4.8.1-arduino2\avr\bin\objdump.exe' wurde ein Virus oder unerwünschtes Programm 'TR/Crypt.XPACK.Gen' [trojan] gefunden.

In der Datei 'C:\Users\Mathias\AppData\Roaming\Arduino15\packages\arduino\tools\avr-gcc\4.8.1-arduino2\avr\bin\ld.exe' wurde ein Virus oder unerwünschtes Programm 'TR/Crypt.XPACK.Gen' [trojan] gefunden.

In der Datei 'C:\Users\Mathias\AppData\Roaming\Arduino15\packages\arduino\tools\avr-gcc\4.8.1-arduino2\avr\bin\ld.bfd.exe' wurde ein Virus oder unerwünschtes Programm 'TR/Crypt.XPACK.Gen' [trojan] gefunden.

A cross check with www.virustotal.com returns a postive result only by Avira. It seems to be a false postive.

Same issue Avira has found TR/Crypt.XPACK.Gen

Then, when trying compiling

collect2.exe: fatal error: CreateProcess: No such file or directory compilation terminated. Error compiling.

Any clue ?

Hello, I have the same problem than moogi. :confused:

:( saludos, a mi me ocurre el mismo problema de virus, probé des-instalar arduino.exe e instalar nuevamente usando la versión que viene en el archivo zip, y me sigue mostrando el mismo error de collect2.exe: fatal error: cannot find 'ld'.

beespitia:
:frowning: saludos, a mi me ocurre el mismo problema de virus, probé des-instalar arduino.exe e instalar nuevamente usando la versión que viene en el archivo zip, y me sigue mostrando el mismo error de collect2.exe: fatal error: cannot find ‘ld’.

Uninstall and Install again does not fix the problem.
You have to check all .exe’s as “Always Ignore” and make sure to restore the files inside Avira Quarantine.
Just did that and worked.

:D excelente ayuda !!!!!, ya funcionó, gracias