IDE doesn't start... Font size must be > 0

Hello,

I get an annoying error message when i start arduino_debug.exe. Look in the Attachment…
How can I change the font size without using the guy?

The IDE doesn’t start… after the splash-screen just nothing happens… :o :o :confused:

This happend because I holdet the strg key and scrolled with my mousewheel... wtf

  • i already restarted my PC
  • deinstalled and installed again
  • the prereferences.txt hast font size 12...
  • the zip-version has the same issue

mathishuettl:

  • the prereferences.txt hast font size 12...

You are probably looking at the wrong preferences.txt file.

This is probably the easiest way to fix the issue:

  • Download the hourly build of the Arduino IDE from http://www.arduino.cc/en/Main/Software#hourly
  • Start the hourly build.
  • Hold the ctrl (I guess you call it "strg"?) key and turn the mouse wheel to change the font size.
  • Close the hourly build of the Arduino IDE.

After doing that the font size will have been changed to a valid value and you can go back to using Arduino IDE 1.8.4. The bug has been fixed and will not be a problem with future releases of the Arduino IDE.

I found the issue and the fix.

Issue is when by accident you change the font size to 0 or less. It happens when you press control and move the mouse over. 2 ways to fix it.

1: if you have not closed Arduino IDE: just go to settings change the font back to 12 or something you want.

2: if you have closed Arduino IDE: go to C:\Users\xxxxx\AppData\Local\
replace xxxxx with your user (on the pc) and then in the local folder look for the Arduino folder, go to the preferences folder.
Do not try to open yet.
Look for editor.font=Monospaced,plain, -xx and change what ever number shows as -xx to just 12 or what ever you desire that is greater than 0
save the file. restart pc. check file again to ensure it did save. then open program again. it should work.