Installation of Driver

I'm new to arduino and I don't know a lot about today's computers. I tried to install the Arduino UNO driver in my Windows 7 computer by carrying out the instructions (several times) and each time got the error message: “Windows could not find driver software for you device.”
I did a search for “arduino.inf” and found it in the Drivers folder, exactly the same place that I had asked Windows to search for it. Please, how do I proceed?

Hi, welcome to the forum.

In that "drivers" folder are also two *.exe files for 32-bit and 64-bit. They will install all the drivers.

Hi Peter

Thank you for attending to my problem. You replied “In that "drivers" folder are also two *.exe files for 32-bit and 64-bit.......”. Well, there was only one such program: there was no *.exe for 32 bit, only for 64 bit, labelled “dpinst-amd64.exe”. I tried the latter, but my computer said it was not compatible with Win32.
I assumed that somehow I’d improperly downloaded the software, so I uninstalled everything and started again. I downloaded arduino 1.6.0 zip and unzipped it to produce the drivers folder, but this did not include the dpinst-amd32.exe I was expecting.
I downloaded the other file (called “Windows Installer”) and ran that, putting its files into a different folder. While it was installing, I was asked if I wanted to execute dpinst-x86.exe, for which I said Yes, but my Arduino still wouldn't load a program. Within the “Drivers” folder of this new installation, there was an arduino.inf folder, but, when I tried to get “Update Driver Software” to find it, Windows still said it wasn’t there. There was no dpist-amd32.exe program there either.
Hence I am no further forward. Please could you suggest other things I might try?

Did you buy the cheapest Arduino Uno clone on Ebay ?
Then it could have the CH340G usb-serial chip, which is not officially supported by Arduino.
You have to install a driver for that, something like "ch341ser" or so.

Is it an official Arduino Uno ? you might try it on another computer, if that also fails, then return it.

If you don't know what this is all about, then make a photo of your Uno. The CH340G chip is easy to recognize.

Hi Peter

Thank you once again for responding, however, I don't think your suggestion is valid. I bought my Arduino UNO from RS-Components in the UK and, after consultation with them, they say that they DID supply me with a genuine Arduino product (according to them, the manufacturer number is A000066).

I tried to run the device on my 64-bit Windows 7 desktop computer, but obtained exactly the same error message “Windows could not find driver software for your device”. I tried a suggestion I found from Dave Burnett about adding a RunOnce message to the registry, but that message already existed, so I don't think that is the problem either. Have you any other ideas, please?

I see, from RS, that is an official Arduino board.
When you open the Device Manager, is something there for the Uno ? Can you find the USB id of it ?

I don't have an idea, sorry. I don't know if it is more likely to be a driver problem or a damaged board. I say, chances are fifty-fifty.
You need another Uno board to check if that is working to be sure that this one is faulty.

Do you have linux ?

Hi Peter

My Arduino Uno does show up on the Device Manager, under “Other devices”, although there is an exclamation mark by it, presumably indicating that something is wrong. I don’t know how to find its USB id; the Tools – Port was set to COM3 by the installer, would there be any point in changing this to COM1 or COM2? The bottom line of the IDE states “Arduino Uno on COM1”, which therefore disagrees with the Tools – Port statement. How do I find out its USB id?

I don’t see how it can be the board that’s at fault, because it would surely be possible to update a driver without its device being present, for my Arduino Uno, Windows just complains that it can’t find the appropriate driver, even though it really is there in the Drivers folder.

I do wonder if the new software for the Arduino 1.6.0 has a fault that has not been noted before, (I had a similar problem with my Raspberry Pi, where the software was out-of-step with the board supplied. I never did get anyone to sort this problem out, which is why I decided to dump the RPi and move to Arduino.) On 13/8/12, eried published a “fix” to install the Arduino 1.0.5, is there anything like this for the Arduino 1.6.0 ?

I’m afraid I don’t have linux. (It was so complicated that it was another reason why I gave up on the RPi !)

My Arduino Uno with ATmega16U2 usb-serial chip is in a project.
So I use my Mega 2560 which has also the ATmega16u2 as usb-serial chip.
I removed the driver, and downloaded the zip-file of the Arduino IDE 1.6.0.

Here we go:
Using Windows 7 64-bit
In the Device Manager, "Other devices", there is it with exclamation mark.
Double click it. Select "Details", select "Hardware-id's".
I get : USB\VID_2341&PID_0010&REV_0001
That means the usb id is 2341:0010
Cancel properties, keep Device Manager open.
Unzip the downloaded file, folder "drivers", run dpinst_amd64.exe
Confirm to install.
The Device Manager automatically updates, and "Arduino Mega 2560 (COM4)" is shown. Without exclamation mark of course.

I don't know what happens when the zip-file is not unzipped. You should really unzip it (right-click on the downloaded file and select unpack or unzip or so).

Hi Peter

The Hardware Ids are USB\VID_2A03&PID_0043&REV_0001, so presumably my usb id is USB\VID_2A03&PID_0043. This is different from your id, does that matter?

I downloaded the zipped file (yet again) and unzipped it to a new folder. Later I located dpinst_amd64.exe and confirmed to install. I then received the information that the driver installation is complete, but the Device manager still shows the Arduino Uno with an exclamation mark.

On trying to upload a sketch to the board, I still get the error message
Arduino: 1.6.0 (Windows 7), Board: "Arduino Uno"
avrdude: ser_open(): can't open device "\.\COM1": The system cannot find the file specified.
Problem uploading to board. See for suggestions."

Again, I noted that this message talks about COM1, whereas the Tools-Port info says it’s COM3 and I can’t see how this number can be changed, clicking on it just makes it disappear.

Hopefully this info may give you some clue as to what we might try next.

Arduino info.jpg

I don't know enough of this, but here is something similar : Windows driver issue with Arduino Due R3-E board · Issue #2686 · arduino/Arduino · GitHub

I think you installed the drivers properly, but there is something fishy with your Arduino Uno board.
A Vendor ID (VID) of 2A03 is not what the Arduino drivers are for.

Is your Arduino Uno like this one : Arduino Official Store | Boards Shields Kits Accessories
Or like this one : Arduino - Home
At front side, at the right-bottom is the text "" or "".

I think you should ask for a replacement.
I hope this doesn't disappoint you. You really tried to buy an official Arduino board.
Maybe it is time buy the cheapest Uno R3 clone there is, 10% chance it doesn't work, but who cares for less than 3 pounds:
The CH340G is not officially supported by Arduino, you need (yet) another driver :
That driver works in Windows, and in Linux the CH340G works without driver. The CH340G can be a problem with Apple.
You also need a USB cable with micro-usb plug.

Hi bobsparkes and Peter_n

I have the exact same problem as you and have done most of the same things as you with the same results.

I ran


and it said driver was installed. I tried Blink program and that did not work (upload error). I also see Com3 in one place and Com1 in another.

I then checked the device manager and no drivers have been installed.

I have tried 2 boards both bought from reputable dealers and I believe they are real Unos

Both boards have a blinking amber LED and a green ON LED

My ID is also ---> USB\VID_2A03&PID_0043&REV_0001

Tomorrow I will try another computer. And maybe installing an older version of the IDE if I can find it.

Please update if you can get yours running and I will do the same if I can get mine up and running.

Maybe it is because it is 2015. I live in San Diego, do you also?? ha ha Maybe UNOs do not work in San Diego.

The text on mine say ""

So you are not alone.


Hi Peter and welcome Roger

My Arduino is indeed the model based on the ATmega328. The description on website Arduino - Home is very full but nowhere indicates there might be a USB communication problem, in fact it states "The '16U2 firmware uses the standard USB COM drivers, and no external driver is needed. However, on Windows, a .inf file is required." The rest of this paragraph is far too technical for my limited knowledge.

What I don't know is whether the version really will work with the recommended software or whether the that I have is the proper version, but that my particular device is faulty. Could you please advise? If the former is the case then I think my next step is to contact RS components again and see if they can replace it with the version. Peter Olsen's post (Windows driver issue with Arduino Due R3-E board · Issue #2686 · arduino/Arduino · GitHub) suggests to me that I either have to make some complicated rearrangements or send it back to RS, I reckon the latter is the best option for me.

I'm delighted that Roger confirms my problem (I was beginning to think I was getting to be too old for this sort of caper). I had very similar problems with the Raspberry PI, and finally gave up trying. In my previous existence I had a BBC microcomputer and was able to make it do everything I wanted - I really understood the 6502 microprocessor. Will I ever master the arduino? Roger asks if I'm from San Diego. Well, not quite, more like 10,000 miles away in Scotland! This may explain why Roger appears to be working at night.

What ! :smiling_imp: :cry: :o
This forum is on the website. We all use boards. The drivers are for boards with vendor ID 2341.

Here is what happened : Arduino V. Arduino | Hackaday
And there you have it. Our beautiful Arduino has become an ugly confusing sad story.
It is a story how open source and open hardware gone wrong.

The seller is right, also the make "official" Arduino boards, but they don't seem to have the usb-serial chip properly programmed.
I'm sorry for bobsparkes and RGBB that you gotten into this mess.
It is possible to use a programmer and write the firmware into the ATmega16U2 usb-serial chip.

Go to and download the zip-file, there is an extra *.inf from for 2A03 boards.

From now on, I suggest to buy the cheapest fake/clone/counterfeit boards from Ebay, until and have fixed this.

I'm only a user of Arduino, just like you, but I apologize for this.

Thanks a lot to all in this topic,

I solved my connection problem started yesterday.

I bought Arduino from RS without any reference to the differences between the boards.... Thanks to they too...!!! :smiling_imp:

Please consider upgrading to 1.6.1. It should fix your issues

I have the Arduino Nano v3.0 (I have two, each in a separate sealed anti-static bag, with USB cable)
Windows 8.1
Arduino IDE 1.6.0

Read everything and tried everything to get this thing working, but it keeps telling me that it cannot find the programmer:
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x01
avrdude: stk500_recv(): programmer is not responding

When I plug the board in to the USB, you can hear Windows detecting something.
I have ran dpinst-amd64.exe and it tells me that installation was successful, but when I open Manager there is nothing to use as drivers.

I have downloaded the FTDI drivers directly from the FTDI site and installed that. Manger detects this but shows "USB Serial Port (COM4)" in Manager. Nothing like Arduino Nano (Com4) or anything similar.
When updating the driver and I use Arduino LLC (, I get Windows blue screen with a message "PAGE_FAULT_IN_NONPAGED_AREA" and the computer restarts.

In the IDE, under Tools I select Arduino Nano board, ATmega 328 processor and COM4 as port (it only shows COM1 and COM4 - COM1 is used for my USB to Serial I use for my PIC programmer).

I am wondering if the Nano has any bootloader. From what I understand LED L is suppose to blink when the NANO board is connected to the USB. How will I know if the Nano has a bootloader installed? (both boards are doing the same).

At this stage I have spent a week on this and the only thing I gained was the IDE software.

Everyone is talking about clones and originals, I know I have the ATmega 328 processer, the FTDI 1226-C USB converter and FTDI drivers(downloaded it from there site.
And what I also know is that the IDE is not communicating to the Nano board


I see that the drivers for are now also in the "drivers" folder of Arduino 1.6.1. Phew, that is a big releaf.

HomerNau, if you bought a Nano from Ebay or similar cheap website, then the FTDI chip is counterfeit.

1.6.1 WORKS for "ORG" boards !!!!

I installed the driver via Device Manager with no problems and in the IDE the COMs agree (Com4 in my case)

and I was able to download Blink. The orange LED (pin 13) is blinking but it was blinking before but I think at a different rate.

Ha I was right - the problem was it is 2015. If we had bought our Unos in 2014, we would not have this problem.


My question is - are there or will there be any more problems with this version of the UNO ??

Thank you Peter !!! Where do you live?

Now I will watch the LED for awhile while I listen to some music ha ha ha And when I get the nerve I will change "delay(1000)" to "delay(2000)"


Hope this works for Bob


Hi Peter

Thank you so much for the advice and the research you have undertaken to discover it.
I downloaded arduino 1.6.1 and unzipped it and then pointed Windows at the new “Drivers” folder. It located arduino-org driver and installed it without question. My Device Manager now tells me that I have an Arduino Uno (COM4) device. I ran the IDE and sent a new sketch to my arduino (it was not as straightforward as that, because Norton didn’t know about arduino and warned me not to run the software. Being a trusting sort of guy, I ran it anyway). I then asked Tools where it was. Tools-Board said it was an arduino uno and Tools-Port gave me two lines, the first (with a tick by it) stating just COM3, whereas the second said COM4 (Arduino Uno – uncertified). I clicked on the COM4 version and, at the bottom of the IDE, it said it was talking to the arduino on COM4. The IDE also said “The board comes from an uncertified manufacturer. We won’t be able to provide any support if it doesn’t work as expected.” When I tried to upload my new sketch, the IDE protested “Access denied” and gave me the “Uncertified Board” message again. Nevertheless, it DID upload the sketch which then ran as required. So I do now have an arduino that works. My problem now is that I don’t have the proper equipment, which may cause problems in future if anything else goes wrong. I therefore intend to return the board to RS Components and request a refund or an version in its place.

It would be nice if the people who created this problem offered an apology for the many hours that I (and Peter) have spent trying to sort out this problem. Peter has apologised, even though it isn’t his fault and he has done a marvellous job in sorting the problem out for me. His advice was understandable to a novice like me and he responded immediately. (My experience with the Raspberry Pi was quite different – when I had problems with it, I got very little help from the powers-that-be and the advice they did eventually send was incomprehensible to me.) So thank you Peter, from the bottom of my heart – you were a real help, even though none of the problem was your fault.

Thanks to everyone else who contributed

Bob Sparkes

I'm glad you both have it running.
I don't know what the consequences are in the future, I'm grinding my teeth about this.

That could be a new project : an Arduino automated teeth grinder.

Every Arduino with FTDI chip from Ebay has a counterfeit FTDI chip. Those won't run anymore, and there could be still thousands of those. So HomerNau should buy an other Arduino board.