Installing arduino mega 2560 on Windows 7 x64

I am having issues installing the driver for the Arduino Mega 2560 on Windows 7 64-bit using Arduino 0022 software. The driver installs, but during the installation process, I get an error message saying that the device could not be started. When I go to the device manager, I see the Arduino Mega 2560 in the Device manager, but there is a yellow exclamation mark by it, and when I look at its Properties, there is an error "This device cannot start" (code 10). It is using COM port 6 on my machine, and that COM port is available. I tried switching com ports, but no luck. I still get the same error. Has anyone had any luck getting these drivers to work in Windows 7 x64?

Any help would be much appreciated.


i haven't used the mega, only the uno. but to me it sounds like an issue with the arduino, not your PC. Make sure when you try to install you select the drivers folder, not the USB...blah...blah...blah folder in it. As well try opening up the arduino software on your PC and select the Mega board as the one your using, i doubt it would make a difference in install but you never know.

Yeah, I believe I am using the right inf file. It’s not the FTDI USB drivers, it’s the mega 2560 inf file. I can select the mega board in the arduino software, but the port it’s supposed to be on is not available. Has anyone successfully installed the mega 2560 drivers with Windows 7 x64?

P.S. The board works fine on a Windows XP 32-bit machine, but I need it working on the Windows 7 64-bit box.

I couldn't get the drivers in 0022 to work with my Arduino Mega 1280.
(more or less the exact same board, just less memory.)

I instead had to go to and pull their WHQL Certified drivers.
(Win64 requires WHQL certified drivers if memory serves me correctly.)

Link to the DL page: VCP Drivers - FTDI

I used the "setup executable" listed in the comments for windows.

Direct link to setup executable:

Hope this helps.

I thought that the mega 2560 board did not use the FTDI chip? Am I wrong in this?

The Mega 2560 does not use the FTDI chip (or drivers).

What if you go in the Device Manager and try to update the drivers? It may give you a more informative error message, if nothing else. Can you try the board on a different computer / operating system to make sure the hardware is okay?

Surprisingly, the drivers welshde posted worked. I can’t explain why, because I understand that the FTDI chip is not used in this board. It works, and that’s all that matters, but I am curious as to why and how this works.

mellis, prior to trying the drivers welshde posted, I had gone through the steps you described multiple times, and I still ended up with the “Device cannot be started” error message. And the hardware worked fine on a Windows XP 32-bit box.

So it’s really odd that this works, but I guess for anyone else having this issue, I would suggest trying the FTDI drivers, and see what happens. Worst case scenario, it doesn’t work, and you are still stuck with the same problem, but best case scenario, like in my case, it does work and solves my problem.

Thanks to all for the suggestions, and especially welshde for the suggestion that worked! :slight_smile:

WHAT ARE YOU doing exactly? you had replace arduino driver with FTDI driver?