Is my Arduino broken? [serial port already in use problem]


I've been making an Arduino program since few weeks. I had no problems with connection or enything else, but today my problem started and I'm starting to feel helpless...

I have Arduino Mega. The problem is, when i want to upload a program [it compiles, no erros etc] an error appears:

This error started to harass me today, after 2 months of making a C# programe that communicate with Arduino without any problems. My C# program is not opened when i try to upload (Even the M. Visual C++ Studio is off). So there is nothing on COM3 working. I tried to reset the Arduino with a reset button - still the same. I tried uplugging/plugging, I turned off COM & LPT Ports in Control Panel -> Device Manager. I've even removed the driver and installed it back. I tried to change COMS, got 3rd, changed to 7th and back etc - error still appears.Changing Arduino bps, moving back to default settings. Nothing. Not mentioning of xxx times restarting computer... I'm working on Windows 7, Arduino 1.0.

Please tell me, it is possible to fix this problem. I hope my Mega isn't broken

Have you tried rebooting your computer? Have you looked in the arduino IDE to see if there is another available serial port?

Yes, i reboot computer houndreds times.
Arduino IDE sees only one port: COM3
changing it’s name (/numer, for example to COM12) in device manager makes no diffrance while uploading:/

Another 2 things i can say:

  1. It’s not the wire - i’ve checked other one, still nothing.
  2. I’ve cleaned the com port in regedit (, after that I removed Arduino from COM3 in COM & LPT Ports in Device Manager, reboot computer, instal it back with the driver, reboot computer again and…? Still:

‘COM3’ already in use. :frowning:

I’m starting to think, that the next step would be the system format :confused:

this is an OS fault, your arduino is fine. format our OS if it come to this.

This happens to me all the time in WinXP. If I have one Arduino attached and I have been programming then all is ok. If I use that same port for something else and then forget to plug in the arduino before trying to send a program, I get that error. Plugging the Arduino back in never works. The only way I’ve been able to clear it is to reboot. It has always gone away.

So I agree that it is an OS problem. You may have actually made it worse by clearing the registry. Try using another usb port. You may have to reinstall the drivers.

I tried using another USB. I've also reinstalled drivers :/ even couple of times

Guess what, now the new problem appeared. I tried to program Arduino on another computer (just the 'blink' example) and I got the same error i used to have on my netbook (belive me, everything needed was done to program it). Now I'm seriously thinking it's Ardu's fault :/

Now I'm seriously thinking it's Ardu's fault :/

Fine. End your frustration. Just put the Arduino back in its box and forget about it.

It can't possibly tie up the PC end of the serial port, but, if you want to blame the Arduino, go ahead.

PM me, and I'll send you an address. You can send me the Arduino for my collection.

“port in use” is a Operative System fault, your PC didn’t even tried to communicate with arduino. if the same problem is on the netbook, and the netbook has the c# program, then probably it doesn’t shut down properly and so it doesn’t remove lock on serial port.

Technically Serial protocol doesn’t have a way to tell if the bus is occupied, because there should be only one thing on the bus. the lock is a way to prevent program that try to share the same serial with catastrophic fail (shared serial buffer)

edit: take a look here:, maybe a malware, maybe some phone/bluethoot/modem software, maybe microsoft ActiveScan

@PaulS: why so rude?

@PaulS: After looking at your number of posts i thought your statement would be helpful or useful. In return, it was just poor demonstration of failed irony. I think showing off is not a reason this forum was created for.

@lesto: Thanks for your interest in my problem. I went through the url you had given. I tried the "serial" in Process Explorer. Nothing found. I don't have Microsoft ActiveSync on my computer too. The url's methods didn't help, but it was worth trying:)

lesto: "port in use" is a Operative System fault, your PC didn't even tried to communicate with arduino. if the same problem is on the netbook, and the netbook has the c# program, then probably it doesn't shut down properly and so it doesn't remove lock on serial port.

C# Program closes serial connection every time it is closed itself. But it doesn't even matter, yesterday, before i wrote the post i had been trying to program Arduino on my brother's computer without this program even on disc space.

Tomorrow my friend will lend me his Arduino Uno. If an error appear while programming, that will mean it is the OS problem.

I'd like to know how it ends, I get my arduino yesterday after a month waiting for it, I'd run a couple of examples on it and play a little bit with them... changing pins and simple stuff to check everything was warking, then I start trying to read serial port with max5 first and with processing later. With max I get it working, but when I tried with processing put me a couple of errors, didn't read the serial port... I get it working after a while.

When I came back to Arduino to load a new program it start saying me that same message:

" Serial port '/dev/tty.usbmodem3d11' already in use. Try quiting any programs that may be using it."

The last program uploaded to arduino is still working, ('AnalogInOutSerial') I tried a lot of things, restarting the computer and starting the arduino with anything else opened, also restarting SMC and PRAM just in case... anything work so far... I trash all processing and max files I had on the computer, nothing yet. I tried with other computers but I couldn't make it work, but other 2 are PCs in bad working condition so no reference here... one is an i3 with W7 last a life to open 'tools tab' and didn't let me open the 'serial port' tab (grey text instead of black).

I'm working with a MacBook with Mac OS X 10.5.8 (I wish this donesn't matter) and arduino 1.0.2 with an Arduino Mega2560

Any other tips will be apreciated.


For XP you can try:,118440.0.html

I tried to solve this problem in that mod updating several things and adding a wrapper to avrdude, for sure is not a Windows problem. Please post the experience (if the problem goes away or not).

Today I get it working on the i3... Really hard to get drivers working in W7 if you are not used to that SO...

Still can't do my mac close the app that is using the serial port, it only use it when arduino is connected, I can use mouse or annything in all USB, but when arduino connected to any USB it start runing something on it, still if arduino isn't sending data, 'Blink' loaded with the i3 and the problem persist.

I'll look for a solution in some mac forums because is a SO issue and not an arduino, maybe some mac users around could help, but I guess a mac forum will be more helpfull.


EDIT: solved here,49173.0.html

Hello everybody!

Same problem. Since days I haven’t found a solution.

Error message: “Serial port ‘NameMac’ already in use. Try quiting any programs that may be using it.”

System(s): iMac Mac OS X, 10.5.8, and same error on MacBookPro 10.7.5

Arduino version(s): Duemilanove, 1.0.2 as well as 1.0.3

Previous attempts, no solution:

  • There is no rxtx.jar or comm.jar files in the Java Extensions folder (it’s EMPTY actually)
  • rebooted, un/plugged
  • When trying to write in the terminal “$ sudo mkdir /var/lock” and “sudo chmod 777 /var/lock” then my password fails o0
  • Crying a lot and smoking cigarettes afterwards
  • Last thing I tried was this, it didn’t work either: Fix the serial port in use issue for Java/Arduino on OS X Lion. · GitHub

Also if this post is kinda often asked, I still can’t find a proper answer to my problem. Do you?

Thank you!




Hi all, first of all sorry for my poor english.

i solved my "serial port already in use" problem but, there are lots of reasons for this problem, so my way can just help a few of you who has the same reasons.

cast: -me -arduino uno r3 -vista 7 -an unknown device using com3

Problem: Arduino IDE software gives an error message as "serial port already in use" and don't load the sketch to Uno R3. In system/device manager, COM3 is belongs to Arduino Uno but my Arduino gives an error as COM3 is using by another device. A schizophrenic reaction.

Reason: i tried to fix this "serial port already in use" problem for 2 weeks but couldn't. I tried lots of softwares and different methods to fix the com port problem. but all of them was unsuccessful.

Than, i remembered that a few weeks ago i removed a flash disk from usb drive of my laptop without using the "remove device safely" function. At this moment windows writes an error code in the system and waits for the correct device again to delete this code.

With this error, any device, a gps or another flash disk can be used safely without an error. Also you can connect the Arduino without any error message. But system detects a virtual device (possibly the old removed flashed) at the same port and blocks the IDE data transfer to Arduino board.

The point here is, Arduino gives the error as COM port problem, but the problem is about USB connection. So the user focus to a wrong point and works on COM ports.

Solution: If you blow away this error code in the system, your problem will be fixed.

This is the way: Write "regedit" to start/run and open it. At opening window you will see a group of folders left side. Choose HKEY_LOCAL_MACHINE \ SYSTEM \ Curr entControlSet \ Control \ Windows \ ErrorMode

Right click to ErrorMode and open. Than change the number (0) to (2)

(If its already (2) dont make any change, this means your problem is not an USB connection problem so my method will not help you to fix this problem)

Restart the computer.

First connect your Arduino to USB, than open the IDE software. Load your sketch.

Have a nice project ;)