Serial port COM3 already in use, tried everything...

I can't upload my sketches because it says: "Serial port COM3 already in use". I have: -Win 7, i'm admin -Processing 0022 -Arduino Mega 2560 connected on port 4

What i already did: -Restarted / "reinstalled" Processing, startet it as admin in XP-compatibility mode -Reinstalled the drivers for the Mega -Rebooted with disabled COM port, enabled and started IDE -Changed COM port number of the Arduino -Pressed the reset button in different intervalls before/during upload. -Searched for a RXTX and comm.jar (in "arduino-0022\java", not in my main java installation, right?). Found nothing. -Closed all programms that could try to access the COM port like Smartphone sync/bluetooth tools etc. -Rebootet Windows in safe mode but the COM port didn't worked because Windows did not loaded the drivers.

Those are the common solutions i found in this forum for this error message, but none of the above helped in my case.

I really would appreciate it if someone could help me :)


Mystery solved: I bought my arduino a couple years ago and thought i bought the Mega 2560 but its a 1280 so i changed that in the "board" menu and it works now... :blush:

-Processing 0022

This is not a valid Processing version.

-Restarted / "reinstalled" Processing, startet it as admin in XP-compatibility mode

Why? The Arduino IDE and the Processing application are completely independent applications. The Arduino IDE is what you should be using to upload sketches to the Arduino.

-Arduino Mega 2560 connected on port 4

If the Arduino is really on COM port 4, the Arduino IDE wouldn't know/care that COM3 is in use.

What you need to do is start the Arduino IDE without the Arduino connected. Make a list of the COM ports that show up under the Tools + Serial port menu item.

Then, close the Arduino IDE, connect the Arduino, and restart the IDE. Check the list of COM ports again. The new one is the one that the Arduino is connected to.

No new ports means that the necessary driver is not installed.

A new port, that still is shown as in use, means that some other application is accessing that serial port. You need to figure out what that application is and not just close it. You must uninstall that application, burn all packaging and documentation for that application, and refuse to ever do business with the asswipes that supplied it.