Java errors when uploading the sketch

The sketch verifies fine but when uploading to chip the upload fails with java errors.

Upgrade to latest java, no help.

Works fine on an older laptop with different version of IDE and java as well as OS.

Laptop is windows 10.

First time i've seen this. Have not tried using this laptop before.

Any ideas??

If you pasted the error message between [ code ] tags, then perhaps there would be a better chance of solving the problem.

Thanks for the quick response. My bad!!! Here is the error message received at the end of the upload. The sketch verifies without error. The code compiles and uploads fine if I use my Windows 7 laptop. Color tag added to indicate what errored.

Part of the verbose compiler responses:

[Archiving built core (caching) in: C:\Users\Don\AppData\Local\Temp\arduino_cache_663634\core\core_arduino_avr_pro_cpu_16MHzatmega328_f7e80a8c3d25f3fcc01353874dae86fe.a
Linking everything together…
“C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-gcc” -Wall -Wextra -Os -Wl,–gc-sections -mmcu=atmega328p -o “C:\Users\Don\AppData\Local\Temp\arduino_build_754374/new_1.ino.elf” “C:\Users\Don\AppData\Local\Temp\arduino_build_754374\sketch\new_1.ino.cpp.o” “C:\Users\Don\AppData\Local\Temp\arduino_build_754374\libraries\Servo\avr\Servo.cpp.o” “C:\Users\Don\AppData\Local\Temp\arduino_build_754374\libraries\Servo\nrf52\Servo.cpp.o” “C:\Users\Don\AppData\Local\Temp\arduino_build_754374\libraries\Servo\sam\Servo.cpp.o” “C:\Users\Don\AppData\Local\Temp\arduino_build_754374\libraries\Servo\samd\Servo.cpp.o” “C:\Users\Don\AppData\Local\Temp\arduino_build_754374\libraries\Servo\stm32f4\Servo.cpp.o” “C:\Users\Don\AppData\Local\Temp\arduino_build_754374/core\core.a” “-LC:\Users\Don\AppData\Local\Temp\arduino_build_754374” -lm
“C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-objcopy” -O ihex -j .eeprom --set-section-flags=.eeprom=alloc,load --no-change-warnings --change-section-lma .eeprom=0 “C:\Users\Don\AppData\Local\Temp\arduino_build_754374/new_1.ino.elf” “C:\Users\Don\AppData\Local\Temp\arduino_build_754374/new_1.ino.eep”
“C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-objcopy” -O ihex -R .eeprom “C:\Users\Don\AppData\Local\Temp\arduino_build_754374/new_1.ino.elf” “C:\Users\Don\AppData\Local\Temp\arduino_build_754374/new_1.ino.hex”
Using library Servo at version 1.1.2 in folder: C:\Program Files (x86)\Arduino\libraries\Servo
Sketch uses 2802 bytes (9%) of program storage space. Maximum is 30720 bytes.
Global variables use 54 bytes (2%) of dynamic memory, leaving 1994 bytes for local variables. Maximum is 2048 bytes.
REMOVE/bin/avrdude -C___REMOVE___/etc/avrdude.conf -v -patmega328p -carduino -PCOM3 -b57600 -D -Uflash:w:C:\Users\Don\AppData\Local\Temp\arduino_build_754374/new_1.ino.hex:i
java.io.IOException: Cannot run program “REMOVE/bin/avrdude”: CreateProcess error=2, The system cannot find the file specified
at java.lang.ProcessBuilder.start(ProcessBuilder.java:1048)
at processing.app.helpers.ProcessUtils.exec(ProcessUtils.java:26)
at cc.arduino.packages.Uploader.executeUploadCommand(Uploader.java:129)
at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:207)
at cc.arduino.UploaderUtils.upload(UploaderUtils.java:78)
at processing.app.SketchController.upload(SketchController.java:713)
at processing.app.SketchController.exportApplet(SketchController.java:686)
at processing.app.Editor$DefaultExportHandler.run(Editor.java:2168)
at java.lang.Thread.run(Thread.java:748)
Caused by: java.io.IOException: CreateProcess error=2, The system cannot find the file specified
at java.lang.ProcessImpl.create(Native Method)
at java.lang.ProcessImpl.(ProcessImpl.java:386)
at java.lang.ProcessImpl.start(ProcessImpl.java:137)
at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029)
… 8 more
An error occurred while uploading the sketch]

You forgot the code tags (</> button on the toolbar).

Typically this sort of problem can be solved by exiting the Arduino IDE and then deleting the C:\Users\Don\AppData\Local\Arduino15 folder (or just renaming it in case you want to revert the action). The next time you start the IDE it will create a new folder of that name. That is the location where hardware packages installed via Boards Manager are installed so you would need to reinstall any packages that you had previously installed via Boards Manager. It is also the location where your preferences settings are stored so you would need to reconfigure your preferences or just copy the original preferences.txt over the new one the IDE creates when the IDE is not running.

Please be very careful when deleting things on your computer. When in doubt back up!

Hi, Please read the first post in any forum entitled how to use this forum. http://forum.arduino.cc/index.php/topic,148850.0.html then look down to item #7 about how to post your code. It will be formatted in a scrolling window that makes it easier to read.

Thanks.. Tom.. :)

Sometimes Java errors are caused by typos in your Arduino code (IIRC a missing quote mark at the end of a string is one of them) that cause the Java system to choke. It seems that the Arduino developers have not included enough error traps.

…R

The issue has been resolved. Deleting the files and restarting the IDE resolved the issue.

Thanks for the responses. :) :)

Hi, Deleting what files?

Tom.. :)