J'essaie un nouveau message - Esperons qu'il est correcte cette fois-ci!

J’ai réviser et réviser mes connections et pourtant, le moteur tourne toujours du même sens “dans le sens des aiguilles d’une montre”

Pouvez vous me dire ce qui ne va pas dans ce programme?

/*
 Stepper Motor Control - one revolution

 This program drives a unipolar or bipolar stepper motor.
 The motor is attached to digital pins 8 - 11 of the Arduino.

 The motor should revolve one revolution in one direction, then
 one revolution in the other direction.


 Created 11 Mar. 2007
 Modified 30 Nov. 2009
 by Tom Igoe

 */

#include <Stepper.h>

const int stepsPerRevolution = 200;  // change this to fit the number of steps per revolution
// for your motor

// initialize the stepper library on pins 8 through 11:
Stepper myStepper(stepsPerRevolution, 8, 9, 10, 11);

void setup() {
  // set the speed at 60 rpm:
  myStepper.setSpeed(60);
  // initialize the serial port:
  Serial.begin(9600);
}

void loop() {
  // step one revolution  in one direction:
  Serial.println("clockwise");
  myStepper.step(stepsPerRevolution);
  delay(500);

  // step one revolution in the other direction:
  Serial.println("counterclockwise");
  myStepper.step(-stepsPerRevolution);
  delay(500);
}

Piper1955: J'essaie un nouveau message - Esperons qu'il est correcte cette fois-ci!

Va falloir changer le titre du message.... et la prochaine fois il faut simplement éditer ton message pour le modifier, parce que là ça fait un peu doublon ;)

Extrait du message "Règles du forum francophone" :

  • Utilisez l'outil de recherche du forum pour vérifier que la réponse à votre question n'a pas déjà été donnée.
  • Pour que la recherche soit efficace, utilisez des titres « clairs » et en rapport avec votre question. Les messages avec des titres comme « A l'aide », « Help » ou équivalents ne sont, en général, pas lus ; donc pas de lecture, pas de réponse.

Inutile de faire du mauvais esprit il suffit de lire. Les titres sont utilisés par le moteur de recherche du forum --> l'icone en forme de loupe en haut à droite du bandeau supérieur bleu.

[u]Les réponses doivent pouvoir servir à tout le monde,[/u] tu reconnaîtra qu'avec le titre que tu as mis tu t'es fait plaisir mais les réponses à tes questions ne pourront pas servir à d'autres.

Alors édite le titre du premier message (#1), mets un texte explicite qui pourra servir à ceux qui utilisent le moteur de recherche du forum dès fois que la réponse à leur question existe déjà.

Merci pour ta coopération.

Ton code c'est l'exemple de la bibliothèque, donc il doit être bon si tu n'y as pas touché. Ce doit donc être un problème de connexion. Quel genre de moteur as-tu ? (référence si possible). Quel arduino utilises-tu ? As-tu connecté comme indiqué [ici[o/url] ?

|500x420

Dans ton cas, les output pins sont les pins 8, 9, 10 & 11 dans cet ordre.](https://www.arduino.cc/en/reference/stepper)