Known issues & bug reports

Please note these warnings and known issues:

  • Only Arduino boards are supported for now, we will support all the boards supported by the Java IDE within a few sprints, thanks for your patience!
  • Do not connect your Arduino board to peripherals (e.g. Keyboard) but to the PC USB outlets of your computer (otherwise not enough power will be drawn and the plugin will behave badly)
  • We have a long list of features to implement, the product you are usign is a work in progress
  • Arduino Web Editor runs only on Chrome, Firefox, Edge and Safari for now, we recommend you use Chrome
  • You cannot upload code from the Arduino Web Editor using mobile phones or tablets yet
  • LINUX ONLY: if you experience upload problem, the troubleshooting guide for Java IDE applies nicely
  • MAC ONLY: we support from MacOSX 10.8 onward

Found an issue? Open a dedicated thread! It would be really helpful if you could add infos on your OS, Browser and the exact flow of what you were doing when the bug happened.
Thank you for making Arduino Web Editor better!


Awesome job I was able to get started quickly and felt right at home. I do have a suggestion and a possible bug.

Suggestion: During the waiting to detect plugin portion of the install it would be nice to see platform specific instructions on where to see the plugin if it started and maybe how to manually start it.

Possible Bug: (Mac OS X El Capitan version: 10.11.1 (15B42)) I get two arduino agent logos in my menubar. I wasn't sure if the plugin had launched and I launched it twice. Launching a third does not add a third agent logo. Pausing the agent on one logo does not affect the other. When launching the debug console one logo just spits out usage and quits the other continuously updates serial info.

Again great job!

thank you for your feedback! we already have a bug on the 2 plugins running at the same time, we will try to address it in the next few weeks.
Also I will add a hint on where to find the plugin in the first configuration flow, we will incorporate it in the next revision :slight_smile:

I tried to re-download the plugin from the Arduino web editor by clicking the yellow bar at the top that notified me that notified me that no plugin was detected. After I clicked and the new troubleshooting window popped up, I clicked download again, but nothing happened.

When I hover over the 'download again' in that pop-up, the link address that my browser shows is: . Entering that link directly in my browser takes me to a static(?) "Welcome Back" page.

I was able to download the plugin again from the "Getting Started" walkthrough.

My system info: Mac 10.10.4 and Chrome 47.0.2526.80


the options "Move file to..." and "Move sketch to..." are not working right now or it's only me that I can't mange them to work:



I also have some visibility issues on both browsers (Chrome and Mozilla):

a)The last line(s) of any text that is written on the editor area and contains more than 29 lines have the last line barely visible (see bellow link)
b)If a project has more than 5 files and are all open if you click the arrow on the editor area to add a new tab the options that appear are outside the visible area of the screen (see bellow link)
c)How can I only open a few files (tabs) from a project not all of them, because now it looks like the are appearing randomly sometimes all the tabs, sometimes only one tab?



System: ASUS F3Sg (Intel Core2Duo 2.4GHz, 4GB RAM, GeForce9300M)
System OS: Windows 7 Pro
Resolution: 1280x800
Browsers: Mozilla firefox 43.0.2 (tested and plugin works)
Google chrome Version 47.0.2526.106m (tested and plugin fails to connect)

Hi, i have tried to control a servomotor with Arduino Create using serial port like an offline version of Arduino IDE but it didn't work. Must i try to change something or it is only a bug?
the code:

Timone.ino (743 Bytes)

you are right, that link is broken, we fixed it some weeks ago, but the fix will be available on staging with the next release. Sorry about that.

'Move to...' options are disabled until you create some folders in which you can move the files into.
Thank you for finding the bug about the last line visualization in the editor, we'll fix that as soon as possible!
About tabs management, we're still working on it, we know there is a lot to improve there :slight_smile:


for a week now I can't see the editor on the create page, neither with http or https, Mozille or Chrome, it's stuck on "Loading Arduino Create..." page and the circle going round and round. I've tried also on Windows 7 or 10.

I'm the only one dealing with this?


@roboticage sorry to hear that!
we haven't had any report on this.

To debug your issue we need to know:

  • your username
  • the browser and OS your are using (I guess Chrome on Win10?)

It would be really helpful if you could provide us with any error that show up on your browser console (right click on browser page, press 'Inspect Element', click on Console tab.



My wepages are stucked at "Loading Arduino Create..." message and it won't go on to the editor page anymore:



"Inspect element shows nothing:


I didn't do anything different from the last 2 weeks when it worked :frowning:


System: ASUS F3Sg (Intel Core2Duo 2.4GHz, 4GB RAM, GeForce9300M)
System OS: Windows 7 Pro 32bit (also tested on Lenovo Thinkpad2 Windows 10 PRO 32bit)
Resolution: 1280x800
Browsers: Mozilla firefox 43.0.2
Google chrome Version 47.0.2526.106m

Hello @roboticage. Could you please make a screenshot of the Network Tab of the Developer Tools, expecially regarding the websockets? I have a hunch that the problem could be there. Possibly from google chrome, which network tools I know better.

Thank you

Hello @roboticage would you also try to login from an Incognito window in Chrome?
Have you installed any Chrome plugin recently?

Sorry this is happening to you, we will try our best to debug this issue!


find bellow the Development Tools => Network for:

Chrome Incognito: (1-webpage expanded, 2-DevTools expanded)


Regarding plugins in Google Chrome yes I've installed "IE Tab" ( and AdBlock looong before but it didn't work before this last plugin instalation and only on Chrome I have installed plugins.
The create website doesn't work for almost 3 weeks now for my use on either computer, even at work.

Can I use another user to see if it has something to do with this user?
I also created "robotized" username.

System: ASUS F3Sg (Intel Core2Duo 2.4GHz, 4GB RAM, GeForce9300M)
System OS: Windows 7 Pro 32bit (also tested on Lenovo Thinkpad2 Windows 10 PRO 32bit)
Resolution: 1280x800
Browsers: Mozilla firefox 43.0.2
Google chrome Version 47.0.2526.106m


I don't know how much it helps but I saw two things:
1)The errors reported in the Console menu under Developer Tools shows some vendor... with a "http" link and under it "https://localhost:8990/inf" even if typed the website with http not https:

2)On my Lenovo ThinkPad2 with Windows 10 PRO and the same browsers Mozilla firefox 43.0.2 and Google chrome Version 47.0.2526.106m the same but with Microsoft Edge when I opened the Developer Tools it worked only 1 single time and the page gone to the initial page where a moving picture of an Arduino board is on the background but that was it nothing works after that on Edge neither!

System: ASUS F3Sg (Intel Core2Duo 2.4GHz, 4GB RAM, GeForce9300M)
System OS: Windows 7 Pro 32bit (also tested on Lenovo Thinkpad2 Windows 10 PRO 32bit)
Resolution: 1280x800
Browsers: Mozilla firefox 43.0.2
Google chrome Version 47.0.2526.106m

Yes, please, try to access with robotized. It should present you with a page saying you have no access (but at least it would mean that it got past the spinning wheel of doom).


I've tried and still not working.
I've tried from other PCs on the company I work and still no result.


Uhm, could it be a particular firewall in your company's network?

Hello! Just joined this awesome project! :slight_smile:

I'm having an error, don know if I should post it here or open a thread with it.

I will report it, if you think may be a new thread is needed please tell me.

Ok, I created a sketch by uploading an existing one I had in my PC.
I connect the board, a Nano v3 from ebay.
I check "Verify" and it gives me "avr-g++: error: missing argument to '-mmcu='".
My question is, does this only works with official boards? I have them, but not right here with me to test it.

Thank you.

@roboticage our last deploy has fixed this issue.

Please restart again the agent from here: and it will start working.