led doesn't blink on my clone

I've made an arduino clone, a pcb paperduino, and some time ago i bought an arduino UNO.

The UNO is working well. When I insert an ATMega328 in the socket the led "L" blinks but if i try the same chip on the paperduino the led connected to pin 13 does nothing. I've revised everything, components values, weldings... and all seems fine to me.

I've tried putting the ATM-328 on a protoboard. I only connect vcc, ground and a led through a 560 ohms resistor connected to pin 19(sck). this is the same uno´s labelled pin 13 , isn't it? but my led keeps turned off. it doesn´t blink.

Any thoughs? What am i doing wrong?

thanks in advance.

If you want to move the ATmega from an Arduino to a breadboard (or Paperduino) you will need to add the 16 MHz crystal and two capacitors on the Xtal lines.

You may be able to program the ATmega to use the internal RC clock. In the folder where your personal Arduino sketches reside, create a folder called "hardware". Within that create a folder called "breadboard". Within that save the text below in a file called "boards.txt". Restart the Arduino ISP and "ATmega328 on a breadboard (8 MHz internal clock)" should show up under Tools->Board This will change the fuse settings to select the internal clock and changes the CPU frequency to match. I don't know if you need to program a new bootloader on the chip. If so you should read about ArduinoISP.

atmega328bb.name=ATmega328 on a breadboard (8 MHz internal clock)

atmega328bb.upload.protocol=stk500 atmega328bb.upload.maximum_size=30720 atmega328bb.upload.speed=57600

atmega328bb.bootloader.low_fuses=0xE2 atmega328bb.bootloader.high_fuses=0xD9 atmega328bb.bootloader.extended_fuses=0x07 atmega328bb.bootloader.path=arduino:atmega atmega328bb.bootloader.file=ATmegaBOOT_168_pro_8MHz.hex atmega328bb.bootloader.unlock_bits=0x3F atmega328bb.bootloader.lock_bits=0x0F

atmega328bb.build.mcu=atmega328p atmega328bb.build.f_cpu=8000000L atmega328bb.build.core=arduino:arduino

Hello johnwasser and thanks, but I've the Xtal and the two capacitors in my board but it doesn´t work yet. I've put the atmega on a protoboard with the xtal.

I put the atmega328 in the UNO board and "L" led blinks. I've measured the voltaje on the pins of the chip, between Vcc and pin 13, and voltaje change from around 5v to 0v as expected, but when i try this on my custom board or my atmega attached protoboard, then there isn´t any voltaje at pin 13´s output.

I've inspected the custom board and the protoboard but i haven't found any mistake in the circuit nor a bad welding so i don´t understand why it´s not working. Don´t know why there isn´t any pin 13 (pin sck) output when attached to my board/protoboard but working as expexted in UNO board.

I´m folowing this same design - http://arduino.cc/en/Tutorial/ArduinoToBreadboard:

except for the pin 1, rx and tx are unconnected and i've added a led and a resistor to atmega's pin 19.

... but i've no idea what i'm doing wrong.

Keep trying for lot of time and finally I changed the atmega to other side of the protoboard. It sudenly worked.
I think I connected the pin to the only broken pad of the protoboard :disappointed_relieved:.

Yet my custom board doesn´t work but at least I know the problem is in the Paperduino board.

So mu board´s led doesn´t blink.

  • 5v to Vcc
  • 0v in ground
  • There isn´t any output at pin 13 (pin 19):

May be a damaged Xtal?
How can I test the Xtal?