M590e gsm module no carrier.

Hello i have a M590e gsm module. The problem is a no carrier in the serial monitor whwn i did a at command to send a text message. I got the correct voltage. The power supply i have can he adjusted work bench power supply. I give is 4.2v up to 4.5v and nothing. Np matter what i find online and tried i can not get it to get a signal. Can someone please help me?

Joseph

What do you mean by "no carrier"? Are the grounds connected? Have you tried using a USB/Serial connector to a computer, or only to an Arduino? Are you using software serial to connect to the module?

The M590E serial speed may not be what you expect. Have you tried different speeds to communicate with it. This guy walks through some of the issues with this module:

https://www.youtube.com/watch?v=yDjy9PL2las

Speeds above 19200 are not likely to work with software serial.

If you mean that you are talking to the module correctly, but it is not connecting to the GSM network, then tell us about your antenna, whether you have tried different, known-good SIMs and so forth.

Once again i goofed up big time. I didn’t put in the information of the whole module and where i got it from and the antenna plus the at commands i have used.

. Let me begin again please.

The module came from eBay here. The antenna is the standard one that came with the module. Im using a FTDI that came be found here. The command i was trying to do is a call just to test so i tried ATD+1XXXXXXXXXX and i have tried ATDXXXXXXXXXX on both times i have tied i get a return message in serial monitor of No carrier.

I have tired different voltages from 3.3v to 3.7v and a 4.2v and 4.5v nothing. I can talk to the Sim i can get the IMEI from it as well as the phone number from it. So talking to the GSM and sim looks okay. But that is all i can do.

Edited: If I’m missing something please let me know.

What does "AT+XBANDSEL?" say? Does it match your expectation for the SIM and network you are using? How about "AT+COPS?"? Automatic network registration will be +COPS:0,xxxxx. What does "AT+CREG?" say about the network registration status?

BTW, I think the M590E is a 900MHz/1800MHz only module. If you are in North America or some places in South America, you'd need a module that can do 850MHz/1900MHz.

Hello the reply i got from all is.

Serial port COM23 opened at OK

+PBREADY AT+XBANDSEL? +XBANDSEL: 900,1800

OK AT+COPS? +COPS: 2

OK AT+CREG? +CREG: 0,2

OK

So long story short the GSM module won't work. It looks like they are using 850, and 1900. Power level is good i can talk to the Sim and can talk to the GSM module but that is all no linking to the cell network.

I looked on eBay and Amazon found a Sim800l and Sim900 with the freq of the GSM chip that will work. Both cost 5 dollars each from amazon plus i can get it next day for free because it's at the warehouse 30 minutes from me. I ordered both and on there way tomorrow. I will post a update. Thank you for the help.

Hello just a update i got the module somewhat working now. I tired a text that i can type in serial monitor to send commands for send text and that works i can get a text on my phone. I tried ATD+1xxxxxxxxxx to make a call and i get a NO carrier message. However i tried another sketch to receive text and calls that works. I'm not sure what to do both sim cards work i can put them in a cell phone to make calls and receive calls as well as send text and receive text they do work.

Edited: good news i got everything to work reason why i couldn't call out is because i didn't put a semicolon at the end of the number. Took me a while to figure that out.