m5stickC esp32 Freezes on "Hard resetting via RTS pin..."

First - I'm a total noob here. This stuff is a little over my head, but I've managed to do a project in the past (🔨 Build with me! Building a tally light for the ATEM Mini with an M5Stick esp32 - YouTube). It worked, but I let the m5stickCs set too long and the batteries completely drained and won't take a charge.

Thus, I bought a second round of m5stickCs and am trying to get the same projects loaded on them. I've tried on two different units and NO sketches that I attempt to upload ever get past:

"Leaving...
Hard resetting via RTS pin..."

Looking at the Serial Monitor, it gives a time stamp and then a bunch of backward question marks (⸮⸮⸮⸮⸮⸮⸮⸮⸮), almost as if Arduino is waiting for it to restart, but it never really does.

I attempt to upload the sketch again, and I see progress in the log, but it always hangs on the reset. I've taken to trying some of the "Example" sketches, and the same thing happens (it seems to upload, goes to restart, then fails).

On one unit, I pressed the power button hoping to reboot the unit, and it seemed to brick it (Arduino doesn't recognize that it's there and can't upload anything to it and the m5stickC's screen is blank). The second unit, I've left on and it's getting warm to the touch. The default accelerometer screen has frozen, but this is the unit Arduino seems to still talk to (though it won't get past the reset).

  • Arduino 1.8.15 (Windows Store 1.8.49.0), Windows 10 64bit.
  • esp32 version 1.0.6
  • m5stickC version 0.2.3

Again, I'm relatively new to this, so first, I thank you for your help. Second, I appreciate your patience and over-explanations!

Thanks for any help you can give!

Is your Seral monitor set to 9600 BAUD?

check your serial monitor baud on code as well as in serial monitor bottom right corner check port and baud are match

Serial.begin(115200); // hence 115200 is baud

Confirmed: image

Thank you for your help!

1 Like

Confirmed: image

Thank you for you help!

1 Like

I "erased" the firmware with M5Burner, then attempted to re-upload my original code.

It's trying to be right. The upside-down "1" in the corner is correct, but it's not in the right place and the flashing static is very wrong :joy:

1 Like

if not working try this
still not works after this links step your sensor should be dead try with another sensor

I hope I'm not an idiot for asking, but I just realized my original units were M5StickCs but the new units (though I ordered Cs) are actually M5Stick Cplus units. Would this be an issue? If so, can you point me to an answer?

Thank you!

Your issues reads as if you have a wire on the wrong pin of an ESP32. Could you disconnect all the wires to external devices and boot the ESP32 does it get past the resetting screen, after all the connections to the ESP32 have been removed? Post your code and a wiring diagram and an image of your project.