MacOS 10.9 and Arduino UNO R3 ATmega328P Driver

I bought a Chinese Arduino which my MacOS 10.9 Mavericks doesn't recognize.
Searching the web I found these links which I've tried them all:
http://kiguino.moos.io/2014/12/31/how-to-use-arduino-nano-mini-pro-with-CH340G-on-mac-osx-yosemite.html

I downloaded several versions of the link (both local repository and Chinese site), I run the terminal command after installing the driver and before restarting the computer.

The driver isn't even added to /Library/Extensions after I restart the Mac.

Any ideas?
Thanks ahead!

Are you sure your “Arduino” has a CH340/341 chip? Look at the chip near the USB connector. It may be an FTDI chip which would use an entirely different driver.

I don’t think it says.
I uploaded some pictures maybe you can help me figure this out.
Thanks again!

That board has an Atmel 16u2 chip, the same as is used on a genuine Arduino UNO. If the chip was burned with the right firmware it should just work (no driver needed). One thing you can try is a different USB cable. If the doesn't "just work" the board is probably defective and you should ask the place you bought it from what to do. It is likely they will ship you a new one.

Still not working with a friend's cable that works for sure. Should I suspect the firmware on the device?