macOS Sierra Serial Monitor working, sync error while uploading

Hi Forum,

I build a small RFID activated lock for a door in my house using an Arduino pro mini with an ATmega328.
I recently wanted to add some key cards to the system so I connected my CP2110 breakout and tried to read the RFID values of the new cards. The first error of not being able to find the serial port the Arduino was connected to was easily fixed by installing the drivers for the CP2110. Already had that problem using an old FTDI so no challenge there. But after reading out the values of the new key cards and entering them in my code, I wasn't able to upload any code to the Arduino. I always get this error:

"avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x9f
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x6b
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x0e
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x0f
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0xce
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xd6
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x43
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x6f
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x98
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x98"

If anyone has had the same issue I would really appreciate help I can't find the solution here.

Does the Arduino reset when you open the serial monitor? Does the Arduino have a bootloader installed? How did you program it before, or is it still unprogrammed?

The Arduino has a boot loader installed and I programmed it with my desktop (Win10). It resets when I open the serial monitor although it sometimes won’t show the startup dialog and Scanner check I have in my code. So I don’t think it resets everytime.

I had a similar problem once: The sketch worked and was sending serial data, but programming was not possible. It turned out that one of the TX/RX lines was not connected, so data flow was only in one direction