Mega 2560 stuck at Uploading to I/O board

This arduino had been working for around 3 weeks but yesterday when i tried uploading a program it stuck at "Uploading to I/O board"

I tried uploading the Basic Blink program and it didnt work either so it is not a problem with the script. I checked and i had my serial port selected (COM4) and my board selected (Arduino Mega 2560) I used different cables (USB) and different USB ports The ON led is on and the L led blinks twice when i connect the board and several times (around 5) when it starts uploading the program

My OS is windows 7 and i repeat the arduino was working perfectly until yesterday. I have a duemilanove which I tried and is still working correctly (that one uses COM3)

I first thought that it was the arduino bootloader but the L led blinks twice when i press the reset button any ideas??? oh and I dont have !!! anywhere in the code as i said, its the blink program (I tried other basic programs) Thanks for your help

Is the device correctly recognized by windows? Anything getting hot?

More information in my signature.

Thanks madworm but i had to give up on it i just exchanged it with sparkfun im doing a project and i dont have much time to fix those things, but i really apreciate your help. :)