MEGA2560 R3 will not load drivers

I have tied on two different computers one was an AMD processor and the other is a Intel processor. On both computers I went to the device manager and tried to update the comport but it failed on both computers. I have followed the instructions to the letter from your help files

If it doesn't have the CH340 chip, you shouldn't be needing a driver.

Post a photo of the module you have.


Will an original Arduino board load drivers differently than a clone?

...tried to update the comport but it failed on both computers.

What is the "comport"?

Do you mean the COM serial port?

I do not think a clone will load drivers differently, I use a clone and everything is fine. A cone is a exact copy of a something, so I would think no, based on my experience and my meager logic. :o

The drivers are for the USB serial port.

Post the Device manager and the HardwareID of the device connected.

Ok, So I have the Mega 2560 project starter kit. This is my firs kit, I have followed the set up instructions to the letter. When loading the drivers for the COM port I get the following error:

Windows encountered a problem installing the drivers for you device

Windows found drivers for you device but encountered an error while attempting to install them.

Arduino Mega 2560

This device cannot start. (Code 10)

if you know the manufacturer of you device, you can visit their website and check the support section for drivers.

We are no where closer to getting needed information.


Here is an image of the board and kit.

ah the dreaded Elegoo

If you have their driver and it is not working, you may want to disable anti-virus or disable signed driver enforcement in Windows 10

It seems that they use FTDI USB UART.

Updated FTDI USB Serial Drivers

It seems that they use FTDI USB UART.

No, it is a 1-to-1 clone with 16u2.
Why do you think is has FTDI?

No, it is a 1-to-1 clone with 16u2.
Why do you think is has FTDI?

Because the manual that teaches how to install drivers from Elegoo contains images related to FTDI device.

i tried updating the FTDI USB Serial Drivers and it still will not communicate with the board, or load the drivers.

Maybe WCH Drivers

The elegoo manuals take forever to update. They are very old, need updating.

And, I have a Elegoo Mega 2560 and on the chip (USB Serial Handling chip) , it clearly says:

1712 PH

If I'm not mistaken, it says 16U2.

Let's hope there is nothing wrong with my eyes.

Maybe this?

Let's see...

Did you install the drivers?

You might have already have but I had the same issue, check if you installed drivers.

That is all I can think off at the moment... :frowning: