Micro OLED only displays SparkFun-logo?

Hello,

I bougth a WeMos D1 Mini along with a Wemos OLED Shield (see attached picture). I followed the Getting Started Guide (http://www.wemos.cc/tutorial/get_started_in_arduino.html) and run the example called “Hello World”. Excellent, I managed to get the Sparkfun logo to display in less than 5 minutes.

The problem is, the OLED display always shows the sparkfun logo. I try to display I simple “Hello World” message and still “SparkFun logo”.

I don’t even know where the logo comes from!?

The code:

#include <SPI.h>
#include <Wire.h> // Include Wire if you’re using I2C
#include <SFE_MicroOLED.h> // Include the SFE_MicroOLED library

#define PIN_RESET 255 //
#define DC_JUMPER 0 // I2C Addres: 0 - 0x3C, 1 - 0x3D

MicroOLED oled(PIN_RESET, DC_JUMPER); // Example I2C declaration

void setup()
{

oled.begin();
oled.clear(ALL);
oled.setFontType(1);
oled.print(“HEllO WORLD”);
oled.display();
}

void loop()
{
}

It would have to be inside SFE_MicroOLED.h Take a look at that file and you will probably see a large logo file in hex.

Mike

As it is a Wemos product and running on a NodeMCU why not ask on their Forum: http://forum.wemos.cc/

Had a quick look at the WeMos stuff out of i curiosity. I see they have an Adafruit library and example, have you tried it? I have got examples from that library working with the Nodemcu and an OLED display.

The Sparkfun logo is indeed embedded in the library you used.

Hello again and thanks for your answer! I appreciate it… = ) I have managed to draw circles and lines without the Sparkfun logo (see attached photo).

The thing is that I can’t draw text. When I draw text according to the example, the oled screen will show the logo as if the code was empty. But when I draw circles and lines, everything works out according to plan.

I had a look in the SFE_MicroOLED.h but can’t fint anything weird or so. I think I’m using the library correct (I hope…) accoring to “drawing text” in:
https://learn.sparkfun.com/tutorials/micro-oled-breakout-hookup-guide

So, I love circles and lines but I sure would like some text aswell =)

Regards
Mattias

Problem solved! Thanks to bodmer! The Adafruit library did the trick for me! It works great so please check out the following page if you read this post and having the same trouble as I had:

http://forum.wemos.cc/topic/73/d1-mini-oled-shield/10

https://github.com/mcauser/Adafruit_SSD1306/tree/esp8266-64x48

Thanks!

show, tks.