MKR Wifi 1010 Module is not Recognized by Windows 10 Computer

Hello everyone,

This is my first foray into Arduino modules and I am trying to set up a MKR Wifi 1010 + MKR Env Shield as a proof of concept for monitoring environmental conditions in growth chambers and greenhouses.

I installed Arduino IDE and respective SAMD drivers for the MKR board but my computer will not recognize the board when plugged into any USB. So far I have tried:

Installing Arduino IDE from the Arduino site by downloading the installer.
I uninstalled that version and reinstalled Arduino IDE via the Microsoft store.
I have swapped out USB-MicroUSB cables and tried various USB ports on my laptop (additionally I checked each port that I tried for responsiveness in the device manager by plugging in a mouse to each one.)
I went back to the SAMD drivers and installed various versions of it to see if one of the older versions might work for initial setup.

Per every forum I have read on this topic I have tried the old double tap of the reset button at every step of this process to ensure there were no changes at any point.
At every step I see all three lights on the board “On”, “L”, and occasionally “CHRG”.
Do I at this point need to consider burning the bootloader onto the board again?

Hi @isleykm. After you do the double tap reset, does the “L” LED start pulsing?

Yes it does pulse. I can provide photos or a video if that would help with trouble shooting.

If it’s pulsing then that means the bootloader is present and functional, so I would look elsewhere for the problem.

Do you see any new device appear in the Windows Device Manager device tree when you put the board into bootloader mode with the double tap?

The same thing happened to me and I was about to give up until I decided to just cycle through all of the USB cables in my house. Eventually I found one cable that will successfully connect the MKR 1010 to my computer.

Even other known-good cables that successfully connect other devices failed to work on the MKR wifi 1010; but for some reason this braided cable (likely the most expensive one that I own) works 100% of the time.

I hope that helps!

Good morning Arduino team and astetson,

Thank you for your prompt replies with helpful tips! This simple exchange has made me very excited to become an active member of the Arduino community!

I had tried the troubleshooting steps that were suggested by the Arduino team as I have seen them in other forums and I was in the process of ordering various microUSB cables, as it turns out not all cables are created equal and one of the new ones was able to establish a connection with the module.

Thanks again everyone!

Sincerely,
Kenny Isley

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.