MKRWAN 1300 US915 TTN Version mismatch?

I'm using MKRWAN 1.1.0 on a MKR WAN 1300 in the US trying connect it though The Things Network.

From the example sketches, MKRWANFWUpdate_standalone updates my board to ARD-078 1.2.3.

Then the example FirstConfiguration checks to see if I'm running 1.2.1 and when it finds I'm not, tells me to upgrade my firmware. But isn't my firmware newer than what it's expecting? Is that my problem?

Pressing on, about every 10th try, I do get a successful connect but I have yet to see a valid payload.

I have an off-the-rack device in here (Victron VE.Direct) that has no problems communicating with TTN so I'm pretty confident in my gateway.

Also, sometimes I can see my EUI in my gateway Live Data.

Yes, there's an antenna attached and I've tried several different ones.

Since the example code is usually set for the EU, I change modem.begin() to use US915. I've even tried US915_HYBRID but it didn't improve anything.

It seems like most people using this in Europe are having success but I can't find anyone trying this in the US. Either there are few or I'm the only one with issues.

Can someone tell me they are having success with this board in the US connecting to The Things Network?

Does my firmware need to be downgraded?

Could my board be bad?

Do I need to wait for an update to the MKRWAN library?

Thanks,
Michael