MKRWAN 1310 unresponsive following boot loader update


I have been having challenges for a while with using the Segger JLink on my MKRWAN and using VSCode too debug. It wouldn’t work and would just stop responding.

With the help of other forums, I concluded that the tool (or I) had somehow damaged the boot loader and I tried to re-install the boot loader that is on the Arduino Core GitHub repository.

I am using Segger EDU Mini as my debugging tool, running on a Mac OS, so last night I went through a forum post to programme the boot loader, now my Arduino is completely unresponsive to the USB port, but is responding to the debugger.

The process I followed was to connect via the JLinkExe toolset
loadbin sam-d21-sam-ba-arduino-mkrwan1310.bin,0

It all reported ok, but now when I double tap the reset button, the mkrwan doesn’t respond and it appears the usb connection is not working. The only lights on the board are the power light (green permanently on) and battery charging (yellow fast flashing), the latter I think means the battery charger chip is not connected to either a battery or the processor.

I had search around the internet last night, but I couldn’t find anything that suggested a resolution.

My first question is have I missed something obvious?

I fixed it.

I tried downloading the same file to the arduino using JLinkExe without success after trying several different ideas.

Finally I tried JFlashLIte and this once again appeared to program the device with the hex file rather than the bin file but then after pressing the reset button twice, it was then slow flashing as it does when in reset mode. VSCode then recognised the device and programmed it without any problems.