more OSX uploading problems

I have read every post related to this topic and most everyone seems to have gotten things working... still I can't. Here's my scenario:
I have just received 10 Arduino Extreme boards, serial numbers (643-652),
I have downloaded Arduino 0003 alpha (twice),
I am working on an Apple Power Book G4, 1GHz, under OS 10.4.3, and have loaded and installed the FTDI 2.0.1 drivers (and restarted).

But every time I try to upload I see the TX led blink, (but never the RX), then a moment later get "Programmer is not responding". I have tried both /cu and /tty serial ports, and every possible speed and combination.
I have reset the board every time before uploading, quit and restarted Arduino several times, and have even tried multiple boards and different USB cables, as well as using USB power and adpter power (moving the jumper accordingly)...
plus I have trimmed my code down to nothing more than void setup(){}... (as well as trying { beginSerial(...); } at different speeds...
still nothing.
And I have run out of things to try...

Anyone have any suggestions?

I had the same problem (with a USB board running OS x 10.3.8 ), but got it working eventually. Same symptoms, same error message, same TX led blink. To get my particular board working, I had to set the Arduino IDE speed on the Macintosh to 9600 baud-- strange but true.

Sounds like you may have tried that already... do the chips have the bootloader programmed in? The quick test is to connect an LED between pin 13 and ground. It will blink briefly on reset if the bootloader is installed.

Finally, there is sometimes a permissions problem with the FTDI driver in OSX. FTDI has instructions on how to fix it:

"Problem: The device cannot be accessed even though the device ID is supported in FTDIUSBSerialDriver.

Solution: An ownership or permissions problem is preventing the system from making the device accessible. Check that the driver is owned by root and wheel. The most common symptom is the group forFTDIUSBSerialDriver is not wheel. To change the group, login as root and perform the followingscript in a Terminal window (Go > Applications > Utilities > Terminal):cd /system/library/extensions chgrp -R wheel FTDIUSBSerialDriver.kextReboot for the change to take effect."

Daniel, thanks for the helpful suggestions.
I saw you had similar problems and I read (and tried) all your posts before posting myself.

One Q: you said "set the Arduino IDE speed on the Macintosh to 9600 baud". I assume you mean the Serial Monitor setting in the Tools menu.
To my thinking that would be the rate that the monitor polls at, which might be different than the actual com port speed. Is there another place to change the overall speed of the IDE (say in the txt pref file?)

So here is my continuing saga (in hopes it might help others):
I checked the file permission of FTDI driver and it was as it should be, owner: root and group: wheel.

I also connected an LED between pin 13 and GND, and yes it does blink on reset (it also blinked when I first started Arduino). I take this to mean the bootloader (thankfully) is installed.
Interestingly the LED also continues to blink about every 10 seconds... I'm curious if this might mean anything.

That said... I am still getting the same "Programmer not responding" message.
I am starting to wonder if it is either an issue with OS 10.4 (Tiger) and Arduino 0003 alpha...
or perhaps the version of the bootloader my boards came with. Is there a way to query the board and ask for the version of bootloader? (I would guess not if it is only 1k!)

Might be time for the Arduino Crew to step in.

(also might be time for them to set up a Wiki, so we can start consolidating our collective knowledge... not to mention fixing little mistakes... like the Extreme board power LED is red, not green!)

yes, by serial speed I meant the port setting in the Arduino 003 application.

Sounds like David will have the answer to this, as in the case of the Arduino board I got at the SFU workshop, it had been specially programmed for 9600 baud.

My only thought is that the FTDI drivers might not be compatible with the latest version of OS X Tiger, which is known to be particularly buggy.

PS: make that two votes for a Wiki! We need somewhere to be able to quickly update the basic information that is being generated/compiled/sussed out.

Also it would be good to have a list of the peculiarities of the different versions of the board, as it sounds possible that different serial numbers of the board may have been set up differently...

So here’s some news:
I have been in the process of switching Mac laptops and accordingly operating systems, from 10.3.9 (on my old machine) to 10.4.3.
I had been trying to run Arduino on my new machine, but given Daniel’s mention above about 10.3.8, I decided to try my old one instead and installed Arduino 0003 and the FTDI drivers… and it works!
I was able to compile and upload the led_blink example and have it run just fine… however a few intereting notes:

  • I was able to use only the USB tty port, not cu
  • The port is listed in the Tools menu as /dev/tty.usbserial-181, whereas under 10.4 it is listed as /dev/tty.usbserial-1B1 (yes the letter B instead of the number 8, I have no idea if this is significant)
  • In 10.3.9 every time I do an upload I first get an error “Error inside Serial.()…” followed by about fifty lines of java messages… and then finally “Atmel AVR…” and then the Arduino message “Done uploading.”… after which my program runs fine.
    [BTW I also see “Firmware Version: 1.18”, so obviously there is a way to query the Atmel]
  • And I was able to change the Baud Rate to 115200, so obviously this version of the firmware supports these rates (sorry Daniel).
    [BTW if there isn’t a way to already, it might be nice to be able to do this from within a program and do something like: if(version < 1.17) { beginSerial(9600); } else { beginSerial(115200); } ]

So the problems I originally posted seem to be related to Mac OS 10.4 and/or the FTDI 2.0.1 driver.

Hopefully the “Team” will be able to figure out wether it is Apple’s implementation of USB under 10.4, the FTDI driver, or the Arduino application.
(In the mean time I am going to upgrade to 10.4.4, just see if it helps.)

Hey, sorry for all the confusion. We’re still getting these things sorted out. The Wiki sounds like a great idea, it should be easy to set one up, as we’re already using one for the Arduino homepage.

What makes things complicated is that there are two independent baud rates:

(1) The download rate.

Used when uploading (aka downloading) a sketch to the board. This has to match the baud rate used by the bootloader that is burned onto the prebuilt boards before they are distributed. Older boards came with a bootloader set at 9600 baud, newer boards use 19200 baud; the IDE defaults to using 19200 baud.

In version 0002 of the software, this rate was settable via the “Serial port speed” menu in the Tools menu. In version 0003, you need to manually set the value of the serial.download_rate item in your preferences.txt file (to find the location of this file, open the preferences dialog in the Arduino IDE) while Arduino isn’t running.

In the future, this is something that should never need to be changed. All boards should come with a bootloader running at 19200 baud, and the software will default to 19200 baud.

(2) The debug rate.

This is the rate that your code uses to communicate with the computer. It is determined by the value passed to the beginSerial() command and the value selected from the Serial Monitor Baud Rate menu. It’s also the value you need to use in HyperTerminal, Processing, etc. to read data from your sketch. Version 0003 of the Arduino software with a USB Arduino board supports speeds up to 115200. Older versions of the software or serial boards only work at 19200 baud or slower. The maximum debug rate is independent of the version of the bootloader on the board.

Some suggestions for try to get Arduino working on your 10.4.4 machine:

(1) Make sure that the serial.download_rate in the preferences.txt file matches the one in the preferences.txt file on the 10.3 machine (and, therefore, the baud rate expected by the bootloader on your boards).

(2) The name of the serial port shouldn’t matter, as long as you’ve selected it in the Tools | Serial Port menu.

(3) Using the 10.3 machine, upload to the board a program that sends data over the serial port at 9600 baud (i.e. calls beginSerial(9600) in setup() and printString(“hello”); in loop()). Then plug the board into the 10.4 machine, select 9600 from the Serial Monitor Baud Rate menu, the correct serial device from the Serial Port menu, and turn on the serial monitor by clicking its toolbar button. Do you see the serial data (e.g. “hello”) in the editor console?

If setting the serial.download_rate preference doesn’t help, and you can’t see any serial data with the serial monitor, there may be some problem with the FTDI driver on your machine, and we’ll need to investigate. We have successfully used Arduino on 10.4.3, though.

Can you post the data that follows “Error inside Serial.()…” in the error you get when uploading your sketch on the 10.3.9 machine? That’s a new addition to the program (to flush any leftover data from the serial port before uploading) and the full message would be useful in getting it working properly.

mellis,
So here's where things are at so far:
Seems I was facing down a number of problems,

  1. Under 10.4.3 I checked the preferences.txt file and serial.download_rate was set to 115200 by default. I changed it to 9600, assuming the slowest speed should work, but with no results. Then, just to be thorough I set it to 19200... and it worked! Knowing then that it does indeed (as you said) work in Tiger (10.4) I decided to upgrade my machine to 10.4.4, just to see if that would have any bearing. While I was waiting for the upgrade to finish I switched a few things around and...
  2. ... when I tried it again, it didn't work (only the TX light and a "not responding" message). I of course wondered if it might be due to the new OS... but also stopped and thought about what else I had changed... which included hooking up a different board (we purchased 10). So out of curiosity I figured out which board it was that was working before, hooked it up... and that one worked!
    I then proceeded to test each board one by one.... unfortunately the news is not good:
    Of the eight that I have on hand* only four work correctly. Of the other four that do not work, three only flash the TX light... and I tried all three boards at all five rates; none worked. The eigth board appears to be truly defective: the RX light comes on solid, Arudino locks up, and I have to force quit the application and restart my computer.
  • and I can not report on the ninth and tenth boards as one has already gone to another instructor (he will test it tonight), and the other is still at my house (where I got it to work last night using 10.3.9... so it is probably safe to assume it will work under 10.4.4. I will try this evening and let you know.)

Also another note: two boards are missing the surface mount power LED. I have no idea if they came off in shipping or simply were never soldered on. However they are two of the four boards that work, so obviously the LED has nothing to do with it.

  1. An important note: Working with the boards that DO work I tested all five download rates... ONLY 19200 works! None of the other speeds (and I did test all four boards at all five speeds, and then all four again @ 19K2, just to confirm they still worked).
    I figured you should be aware of this. If this is not the case with PC's and Linux you may want to talk to FTDI about it. I'd also advise you make this the default speed in the prefs file for now... and you may want to post instructions for Mac users on how to manually change the prefs file. (not just here on the forum but on the site as well).

So sorry to be the bearer of bad news... I could joke and say that it is only half bad... but as you can imagine I am rather dissapointed to find that nearly half our boards are not working.

Robb

For reference, I sent an email to FTDI yesterday asking which versions of OSX are supported by the USB chip in the Arduino, and this was their response:

"Mac OSX drivers have been tested on version 10.4.2. We have yet to update the machine to 10.4.3, so have yet to verify if the driver works under this version, however we would be expect it to work. "

PS: Seems like there are some growing pains with the Arduino, but I am still very excited about the possibilities! We are teaching 60 students this semester here at Simon Fraser University how to prototype design projects with the Arduino. The dialogue we're having in this forum about the roadbumps along the way is good... I'm sure things will stabilize soon re Arduino versions.

Hej,

I just updated the FAQ with some of the results to this post:

It includes three screenshots showing how to find the properties' file. We may add a special feature at the preferences pop-up to do this change without looking for the file. In the meanwhile follow the procedure mentioned in the FAQ, please.

On the other hand, about the wiki, I also agree we need to get one part open for everyone to generate documentation. Right now we are bit overloaded, but in a couple of weeks I am confident we could fix something. However we have been giving access to our wiki to some people that have requested it for helping out with the reference. I am mentioning this as a middle-way solution. Are you interested in giving a hand Robb or Daniel? We are willing to get some more help :slight_smile:

Finally, the problems with the boards that rdrink is mentioning seem to be because of a mistreatment of the boards during shipment or a manufacturing failure (what sounds strange to me, since I usually get packages of 50 boards at once, perfectly tested and carefully packaged). However, I am sure that Gianluca will be willing to cooperate and compensate you in this one. You should write him telling about the problem: boards with no power LEDs, problems with a missing bootloader, etc. I am sure he will be helpful and eventually will even send new boards. You should probably take a digital picture of the boards you got and he will tell you how to proceed. (Please note that I haven't spoken to Gianluca about this, he sits in Italy and I am in Sweden, so when contacting him tell him the story from the beginning).

Thanks for the comments, Arduino is a fast growing community and all your help, ideas, critique, and support are needed!

/David

David,
Yes I will be glad to assist in adding content to the wiki.

Re the problems with my boards: how do I contact Gianluca? I will be glad to send him a detailed description of everything if you can provide me with an address (you can contact off list if you need to).

Robb

Hello richard

You can contact gianluca at g [dot] martino [at] smartprojects [dot] it

I've asked him to get in touch with you already.

Reading about your problems I think something must have happened during shipping because each board is individually tested before being sent out.

This is also the first time we had faulty boards but the policy we estabilished with gianluca is that he will replace them with no problems.

sorry you had so much troubles

massimo

one more thing

I don't mean to be a pain in the ass but please make one last test:)

please run the macosx_setup.command that you find in the arduino-0003 folder while making sure that your account is an admin on the computer (you can verify that in "Accounts" inside "System Preferences")
after you successfully run the script please shut down the machine. don't reboot.. don't logout... really turn it off.. I know it sounds a bit windows-like but this has fixed problems quite a few times.

massimo

Hi

We have received the Arduino extreme boards at kingston, thanks for this.

I've tested the boards with the IDE v3 on Windows XP(which uploads fine), I've done the same on Tiger OSX 10.4.4 - and I'm finding that there are problems uploading.

  • I've upgraded the FTDI USB Serial drivers to v2_1_0.

  • I've run the macosx_setup.command and shutdown X.

  • I've set serial port to /dev/cu.usbserial-151

  • I've set the serial baud rate to 19200

  • I've set the serial_download rate at 19200 (in preferences.txt), and the baud speed at 19200.

The 'programmer is not responding'

Could someone let me know if there are any updates with 10.4.4

thanks

It all looks good

Is the jumper SV1 connected correctly for the type of power you are using?

if you are using usb it should be connected between the central pin and the one next to the USB plug.

Every board is individually tested and a software is downloaded via the usb plug. This makes us fairly confident that there are no issues when the board leaves italy.

Unfortunately being cross platform for us is a blessing and a nightmare as we have to test a lot of combinations of OS and drivers... :slight_smile:

let me know how it's going

massimo

the jumper SV1 is on the right side, yes.

I still get problems on 10.4.4 - i will test it on 10.3.9 tommorow and let you know.

cheers