My MKR1000 wont let files be uploaded to it, please help!

I’ve tried many time to solve the issue by myself, but every time it’s a flop.

  • The built-in LED is on
  • The MKR1000 won’t show up in COM & LPT or even in Unknown Devices
  • Cable seems to be working with on other devices
  • I tried uninstalling the Arduino IDE and restarting my PC, and that failed

Please help.

A few more details required such as OS and USB connection type 2.0, 3.0 etc.

When this post is moved to the correct section there are a few posts you might want to read that may be helpful.

Yeah, I only use USB 2.0.

My cable is a data cable as well.

And I read the FAQ, tried to quick press the RST button two times, nothing happened.
But thanks anyways for the reply

It may take you a few tries to get the timing right on the double reset button trick you have to do it quite quickly.

I pressed the buttons on the board faster than an eSports gamer... And result : NOTHING

RIP me

Somebody help me please I really want to continue making stuff, please!

If it fails to make the "NEW HARDWARE FOUND" noise under windows. OR Does not show up in device manager in windows either as a COM port or other device that needs attention. AND You have tried multiple USB cables that are DATA and POWER (they are not all the same). AND You have ruled out USB 3.0 issues by using USB 2.0 OR You have tried it on other computers to see if they can see it.

Then I am not sure what else there is to try.

Same problem with my MKR 1000 board.
I have tried all the mentioned solutions…

@Bjain

Not enough detail of your particular issue to make even a guess.

“ME TOO” type questions are useless so please add lots of extra detail.

My issue is that when I plug my board into my computer is that the MKR1000 board will not show up in device manager, the 'on' LED is switched on, I go to the Arduino software and check if I still upload projects to my board. It doesn't work. I tried all the mentioned solutions, I'll make a list :

-The new hardware sound does not come when I plug it in.

-I've tried using three different cables off them are 2 data cables and 1 power cable.

-I only have USB 2.0 on my laptop.

-I tried it on other devices(two, both running windows 10).

-Also I tried to send the CPU into bootloader mode but that didn't show anything

I have 5 MKR1000 boards.

2 of the 5 are not getting detected on any com port, doesn't even appear in any unknown devices category.

They don't even make any sound when connected, while other 3 are working normal.

I have uploaded program on them earlier, but now they act like they are dead.

On board LED glows definitely but they don't do any processing.

The sketch uploaded on them when they were working, doesn't work anymore on reset.

Double tapping reset button - doesn't work.

@SmokingKrills

In your case its pretty safe to assume that you have a dead MKR1000.

@Bjain

The double tap is timing critical and you could practice that on one of the working boards as you will see when it goes into bootloader mode. in device manager as it will come up with a new COM port.

Other than that you too may have a couple of dead ones.

N.B. To both of you make sure you have nothing else connected to the boards during testing.

Is there any specific condition in which MKR1000 becomes dead..

@Bjain Thousands of reasons.

Over voltage via any components. Incorrect wiring. Placing on a metallic surface when powered. Careless soldering solder splashes on the board. Leaving in the anti-static foam whilst powered up. Over exertion on the board or its components.

The list of things that will let the magic smoke out is as long as your arm and all of them only take a fraction of a second to do the damage.

Well, I am sure there is none from the top 5 you mentioned, besides my MKR1000 is with headers, so soldering is also out. How can overexertion on the board be defined. I have read similar post for MKR 1000 not getting detected during a sketch upload due to some error messages..

Is there any hardware based testing to detect the problem with MKR1000?

People have soldered other items in close proximity to Arduinos so just because it had headers doesn’t mean its immune to the issue.

I can define over exertion pretty well with a picture of a board that arrived quite recently.
Also people have been known to put too much pressure on the USB connectors and break them off boards or tear the tracks etc.
Others have bent pins or wire leaving parts in the headers that are a PITA to get out.

As far as hardware testing you said you followed all the advice you found so if its not seen by multiple computers with multiple cables and trying the double tap reset trick then there is little else you can try.

If you have access to a well equipped lab and the skills and expertise to chase a schematic around you could go further but that is way beyond the viability of the board.

broken tracks.jpg

Yeah so thanks for helping, I now have a ded board. However all of the causes for a ded board above did not match up with mine.

Would I still be able to get a warantee, I got the board less than 2 months ago.

@SmokingKrills

I don't work for Arduino so I have no idea about what you would do for warantee items I am just another user like the rest on these boards.

That's for you to work out.