Nano is Stuck in "Uploading" signal

So I'm just getting into arduino's, and for my first permanent project, I got a nano, so I can easily upload my code in, and have everything securely soldered. So, I got my nano in the mail recently, I hook it up to a breadboard, I plug in a simple LED circuit, and upload the following code:

void setup() {
  // put your setup code here, to run once:
  pinMode(6,OUTPUT);
}

void loop() {
  // put your main code here, to run repeatedly:
  digitalWrite(6,1);
  delay(1000);
  digitalWrite(6,1);
  delay(1000);
}

And then, it's stuck "Uploading Sketch"

The light turns on when I plug it in, so the arduino seems to work (at least the on-board LED)

Help please?

Please do this:

  • (In the Arduino IDE) File > Preferences
  • Uncheck the checkbox next to “Show verbose output during: compilation”
  • Check the checkbox next to "Show verbose output during: upload
  • Click “OK”
  • Sketch > Upload
  • After the upload hangs, click on the black console window at the bottom of the Arduino IDE window.
  • Press “Ctrl + A”. This will select all the text in the console window.
  • Press “Ctrl + C”. This will copy the selected text to the clipboard.
  • In a forum reply here, click on the reply field.
  • Click the </> button on the forum toolbar. This will add the forum’s code tags markup to your reply.
  • Press “Ctrl + V”. This will paste the upload output between the code tags.
  • Move the cursor outside of the code tags before you add any additional text to your reply.

Hopefully the verbose output will give us some clue to what is happening when the upload hangs.

Update: I just realized that after leaving it upload for a few minutes, it says there was a problem uploading to the board, saying:

Sketch uses 912 bytes (2%) of program storage space. Maximum is 30720 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.
C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM4 -b115200 -D -Uflash:w:C:\Users\Jack\AppData\Local\Temp\arduino_build_431945/NanoLedBlink.ino.hex:i 

avrdude: Version 6.3-20171130
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

         Using Port                    : COM4
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x87
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x87
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x87
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x87
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x87
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x87
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x87
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x87
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x87
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x87

avrdude done.  Thank you.

Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

Yeah, that's an annoying thing about having verbose output during upload turned off. You have no indication of whether anything is happening. For this reason, I always leave verbose output during upload turned on.

Select Tools > Processor > ATmega328P (Old Bootloader) and then try uploading again.

2 Likes

pert:
Yeah, that's an annoying thing about having verbose output during upload turned off. You have no indication of whether anything is happening. For this reason, I always leave verbose output during upload turned on.

Select Tools > Processor > ATmega328P (Old Bootloader) and then try uploading again.

It works now! Thanks! Also, if I'm switching between the Uno and my Nano, do I have to switch the processor between the old boot loader and the current one?

You're welcome. I'm glad to hear it's working now.

The Tools > Processor menu is specific to the Tools > Board > Arduino Nano selection. It has no effect once you select Tools > Board > Arduino/Genuino Uno. In fact, you will find that the Tools > Processor menu disappears when you have the Uno board selected.

1 Like

pert:
You're welcome. I'm glad to hear it's working now.

The Tools > Processor menu is specific to the Tools > Board > Arduino Nano selection. It has no effect once you select Tools > Board > Arduino/Genuino Uno. In fact, you will find that the Tools > Processor menu disappears when you have the Uno board selected.

Alright, big thanks for the help!

Sketch uses 936 bytes (2%) of program storage space. Maximum is 32256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.
Sketch uses 936 bytes (2%) of program storage space. Maximum is 32256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.
C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.33.0_x86__mdqgnx93n4wtt\hardware\tools\avr/bin/avrdude -CC:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.33.0_x86__mdqgnx93n4wtt\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM3 -b115200 -D -Uflash:w:C:\Users\abmta\AppData\Local\Temp\arduino_build_321743/sketch_jun15a.ino.hex:i

avrdude: Version 6.3-20190619
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is "C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.33.0_x86__mdqgnx93n4wtt\hardware\tools\avr/etc/avrdude.conf"

Using Port : COM3
Using Programmer : arduino
Overriding Baud Rate : 115200
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x57

muhammad771991:

         Overriding Baud Rate          : 115200

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x57

Select Tools > Processor > ATmega328P (Old Bootloader) and then try uploading again.