NEO-6M GPS Module heating, LED off

Hi, I bought this GPS module uBlox NEO-6M. I want to test it with Arduino Mega. I followed the example code in TinyGPS library. But the module is not working. The led does not turn on at all. There is no output on the serial port. And one thing I noticed is that the resistor (to the top right, near the Vcc pin) gets really hot. I tried both 3v and 5v from the Arduino. I disconnected the Tx and Rx pins and made sure nothing was short circuited. I read somewhere that I should keep it on for an hour to charge the battery. I’ve done that and the battery is charged (I checked using a multimeter). But the module is still not powering up.

Please tell me what should I do. Should I contact the seller and tell them the module is dead?

There is no pin labelled VCC ?

Does the board or components get hot when only GND and VCC are connected ?

if you got that from banggood there are people who complained about receiving a defective module. The chip is not new and is not an original… so it’s cheap but…

The pin on the top right in the image is Vcc, it’s labelled on the other side.
Yes, it gets hot when only Ground and Vcc are connected. Still no LED

Not Bnggood. It’s a local store that imports directly from China.

If it’s a local store, take it back and try and get your money back.
There’s not much difference between the local store Chinese stuff and the Banggood Chinese stuff.
The chances are, the store will say it’s your fault, but Banggood are better for getting your money back.
I’ve used AZ or something or other GPS modules with the Ublox module on it and they work fine.
Not a good start to using GPS. Pay a bit more and get something from Sparkfun or Adafruit.
I hope your Mega (2560?) is genuine.
This forum is awash with problems starting out on projects and putting cost before quality and ending up wasting time and losing confidence.

The brown-ish part, top-right, is a (100n?) supply smoothing capacitor (from VCC to ground).
If that one gets hot, then that capacitor could be the only problem.
If you can’t return the board, then gently swipe it off with a soldering iron.
Leo…

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.