Neopixel only red light after cutting on marked location

Hello,

I bought a neopixel ws2812b led strip which worked perfect. It had 60 leds, which all worked great powering from an external power supply, as well as from my laptop battery for a short amount of time.
I cutted these after 10 leds between the soldering points (marked location), and they stopped working. Both the 10 leds and the 50 leds. I cutted the 50 leds to get only 1 led, 3 leds, 40 leds but these behaved similarly.

As can be seen in the images above, they only shine red light. So I thought the power was too low, so I blew up some. I think I also blew op 3 as can be seen in the last image, by putting the data line on the 5V power supply.

I checked the power, which was 5.04 V. I added a potentiometer between data of the arduino and data of the ledstrip, but without results when going from 0-5.5 Ohm.

I added in my script that only the first 3 should come on, but they don't react to it anymore. The datapin, arduino, power supply and led strips are all the same; the only difference is cutting these. Does someone have an idea what I could do more or know the reason why they don't work anymore?

Thanks in advance!!!


The second image :slight_smile:


Last one.

Thanks in advance!!

Follow this wiring:

In the Arduino IDE, use Ctrl T or CMD T to format your code then copy the complete sketch.

Use the </> icon from the ‘reply menu’ to attach the copied sketch.

did you adjust the number of leds in your program after you cut them?

Wow! There are some seriously bizarre things going on here!

How can you power them from your laptop battery?

What exactly is happening in your first image? Three lit, the others dim red. Is that what you get with no data connection?

Hardly surprising as it makes no sense!

This all suggests some truly horrible wiring mistake.

I surely hope you disconnected everything before cutting.

Based on the first image, your power supply seems to be missing a regulator.

By the way, if you have a 12 Megapixel image, post a 12 Megapixel image. Removing detail (or not having it focused) makes it far less useful.

You can’t connect the cut end by pressing three patch wires to the end. The resulting bad / intermittent contact you are bound to get because of this while running the code, you will have burned out your LED strip. I know it happens to me once plugging in a 3 pin header plug and socket while powered up.

You need to solder the thee wires onto the strip to make the connections on a cut end.

Hello,

Thank you all for the answers!

After cutting, I adjusted the number of leds in my program, but without results.

I powered the leds by the 5V and gnd on the arduino Nano, and powered the arduino by a usb cable.
What happened in the first image is that I connected the data to the 5V input, and then I think I broke my 3 first leds. This also happened when I put 8V to the leds; some shine a lot brighter afterwards, also on 5V.
I saw that a 470 Ohm resistor should be added to the Din, that's why I added instead a potentiometer. Why does this make no sense?

Yes before cutting I disconnected everything. The power supply was in this case a simple transformer, which isn't stabilized so I was quite happy to get it on 5.04V with the Voltmeter.

Sorry for the image detail, I actually had a .jiff file which I couldn't upload, so that's why I transformed it to .png by snipping tool.

The soldering seems like a good idea, so I will try this. Are there some other things I could try?

Thanks in advance!!

A transformer outputs AC. That is pretty certain to fry anything you connect to it that runs on DC.

Yeah true, I wasn't clear. This transformer can output AC as well as DC, so I connected it to the DC output.

By the way, I soldered it together and it does not make any difference. What is noticable however, it that all leds are again turned red, instead of the first picture. So I think something is wrong with the data.

OK that is another way to blow a strip, even easier that the other stuff. I would be surprised if any addressing was consistent.

I think your best bet is to start with a fresh roll of LEDs.

Okay, I encounter some strange behaviour now. I used an arduino uno instead, with the same sketch/script (but bootloader for Uno of course) and now the leds are always off. I checked and the voltage of the data pin is always same as ground. So I declared 'pinMode(3, OUTPUT);' in the 'setup()', but without results. I checked if the script would run by using the builtin led. And the strange thing is, it doesn't. So when I remove the 5V pin from the neopixel, the arduino starts blinking 3 times (I added 2 times in my script, but this is from startup I read somewhere). But if I add power to the breadboard with neopixel, the arduino doesn't do this. Looks like the arduino goes in safe mode, even while the voltage over the arduino is 5V and no other pins are connected.

Does anyone maybe now know what I am doing wrong?

As far as I can tell you're working with a series of leds you've probably destroyed at some point and they're now giving problems.

I second this.

Sadly there is no such thing as a safe mode.

Sounds like your Arduino is screwed as well.

Hey! Something blinks, maybe it's not too bad.

I am suspecting some confusion with pin numbers and code. :roll_eyes:

Okay so I bought another Neopixel with 60 leds and I knew my trafo can't handle that amount of current. So I also used another stable 5V power supply, which worked with my arduino and neopixel. I also tested the previous (broken) neopixel, and I saw that these also worked. I think the problem was that my previous power supply couldn't handle that much current. So no issues with wrong wiring (I didn't use 470 ohm resistor as well as capaciter).

Thanks all for the comments and your time!!

Apart from the fact

Why ask for advice and then ignore it?