No serial connection with Olimexino-32U4 (Leonardo)(Solved!)

Hi at all! I really hope someone can help me with my problem: I've got my Olimexino-32U4 today and i'm desperately trying to establish a serial communication between the board and my PC for about three hours now. I am using Arduino 1.0.3 on a fresh Win7 install. Uploading sketches works without a hitch. The TX LED is permanently lit and the RX LED blinks when something is sent via the serial terminal. Arduino Uno serial works, btw.

Stuff I already have tried:

Arduino IDE serial monitor: no output PuTTY: no output Processing: no reaction reflashing the (Leonardo) bootloader: nothing changed reinstalling the driver: nothing changed checking device properties: everything okay there And most importantly: restarting my computer didn't change anything.

After that ordeal I uploaded this simple sketch:

byte led = 7;

void setup() {                
pinMode(led, OUTPUT); 
while (!Serial) {  }

void loop() {
  digitalWrite(led, HIGH);
  digitalWrite(led, LOW);

If there is a serial connection, the LED on pin 7 (there's no pin 13 LED on Olimexino) should blink. Guess what: It doesn't. I'm really out of tricks and completely confused now :~.

This is your board, You already flashed the bootloader. I hope you used the Arduino IDE 1.0.3 for that, since the Arduino IDE also sets the fuses during flashing of the bootloader.

The (virtual) serial port via the USB is a software serial port. During development of a sketch, it is best to wait until the serial monitor is opened.

// wait for serial port to connect. Needed for Leonardo only
while (!Serial) { ; }

Add some code in setup to show something on the serial monitor, so you know it is running

void setup() {                
  pinMode(led, OUTPUT); 
  while (!Serial) { ;  }
  delay( 500);
  Serial.println("Hello World");

You missed that empty statement ';' between the brackets.

Add that missing ';' Upload the sketch, wait until it is done. The Arduino starts running the sketch and waits. Open the serial monitor. The Arduino continues with the sketch and shows "Hello World".

I can't help with the leds, I don't have such a board.

Yes, I did use Arduino IDE 1.0.3 for flashing the bootloader. Changed the code, uploaded it and again no success. This is getting weird :(

Very weird. Did you see the text on the serial monitor ?

There was no text at all. I'll try it again with Ubuntu as soon it's installed completely.

Edit: Reflashed the bootloader with Arduino IDE 1.0.1 on Ubuntu, it's working now, yay! (Gosh, that took me almost nine hours) XD The serial monitor in 1.0.1 works in Ubuntu and Windows. PuTTY works too now. Serial in 1.0.3 still doesn't work. I tried the official release and the enhanced release (The enhanced release is great nonetheless, it's just so comfortable), it didn't work in both. Seems to be a bug in 1.0.3, could someone please take a look at that?