Once working Arduino

I got my arduino like 6 months ago and it worked perfectly fine. I kinda learned how to use it but I decided to take a break for a while. Now when I try to use it, it doesn't want to work. I used it on a Windows XP when it worked and now I'm trying to use it on my laptop which is a Windows 7. It is a Duemilanove with an ATMega328. When I try to upload any code, it says,

"avrdude: stk500_getsync(): not in sync: resp=0x30 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51"

I've read other forum topics on this but nothing helps.

You have the FTDI drivers installed? You are selecting the correct board type, and COM port, under tools? The COM port has a check mark next to it?

Does the COM port show up in device manager? (my duemilanove always shows up as COM3, while my FTDI basic adapter always shows up as COM7).

You may need to run the IDE as Administrator. I got the same error with a newer UNO on both Vista and 7 Pro, and that alone cleared it up.

Seeing as that is the simplest solution, try that first. If that doesn't work, then go to the next troubleshooting step (in this case, new drivers, which may need to be installed anyway).

Yes I have the right board selected, I only have COM3, my FTDI is current, I have looked at the troubleshooting, I tried running it in administrator, and it still won't cooperate with me. Any more ideas? :(

And you're sure COM3 is the Arduino (either from the Device Manager, or by unplugging it and making sure COM3 disappears)? Check: http://www.arduino.cc/en/Guide/Troubleshooting#upload for some other suggestions.

On my device manager, there is no COM3, the port is called "USB Serial Converter". That dissappears when I unplug the Arduino but COM3 on the ICE doesn't go away.